Pada artikel kali ini kita akan belajar cara mengkonfigurasikan Peers BGP Eksternal antara R2 (AS-12) dan R3 (AS-3) menggunakan interface loopback masing – masing router.

Masih menggunakan topologi sebelumnya, seperti di bawah ini. Simulasi ini dilakukan di GNS3.

topologi

Petunjuk Lab

1. Advertise IP loopback 0 pada R2 dan R3 menggunakan RIP.

2. Advertise interface serial antara R2 dan R3 menggunakan RIP.

3.  Buat IP loopback baru di R3.

4. Konfigurasi eBGP Peers antara R2 dan R3 menggunakan loopback.

 

Konfigurasikan masing – masing router anda dan ketika di show run akan muncul seperti di bawah ini.

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 1.0.0.0
network 12.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router rip
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 12
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 255
neighbor 3.3.3.3 update-source Loopback0
no auto-summary

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router rip
network 3.0.0.0
network 23.0.0.0
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

 

Setelah selesai melakukan konfigurasi seperti di atas, langkah selanjutnya adalah melakukan verifikasi. Hal ini bertujuan untuk memastikan konfigurasi yg kita lakukan benar dan jaringan berjalan dengan baik.

ping

sh ip bgp

sh ip route