Setelah mempelajari internal BGP kini saatnya mempelajari cara menjalin koneksi dengan AS number yg berbeda pada routing BGP, atau yg sering disebut dengan eBGP.

Tambahkan 1 router di sisi R2 dari topologi sebelumnya.

topologi

Petunjuk lab

1. R1 dan R2 masih menggunakan pengalamatan seperti pada artikel sebelumnya.

2. Tambahkan konfigurasi IP antara R2 dan R3.

3. Buat eBGP peers antara router R2 dan R3.

4. Konfigurasikan IP loopback di R3 untuk di advertise ke BGP.

Konfigurasi masing – masing routernya sebagai berikut.

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 1.0.0.0
network 12.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback1
no auto-summary

 

R2

interface Loopback0
ip address 22.22.22.22 255.255.255.255
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router rip
network 2.0.0.0
network 12.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback1
neighbor 23.23.23.3 remote-as 3
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 23.23.23.2 remote-as 12
no auto-summary

Verifikasi hasil kerja konfigurasi anda, ping dari ujung ke ujung. loopback r1 ke loopback r3, loopback r1 ke loopback r2.

ip bgp

ip route

ping 2

ping