BGP merupakan salah satu routing yg ptg dan harus kita kuasai apabila ingin meraih gelar CCIE, berikut ini kita akan mempelajari cara mengkonfigurasi routing BGP pada cisco, di mulai dulu dengan internal BGP yang merupakan konfigurasi paling dasar dari routing BGP. Yaitu BGP dengan AS number yg sama.
Buat topologi seperti di bawah ini, kali ini saya mensimulasikan pada GNS3. Tiap router memiliki AS number yg sama yaitu 12.

topologi

Konfigurasikan router sesuai dengan konfigurasi di bawah ini.

R1

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 12.12.12.1 255.255.255.0

duplex auto

speed auto

!

router bgp 12

network 1.1.1.1 mask 255.255.255.255

neighbor 12.12.12.2 remote-as 12

no auto-summary

 

R2

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 12.12.12.2 255.255.255.0

duplex auto

speed auto

!

router bgp 12

network 2.2.2.2 mask 255.255.255.255

neighbor 12.12.12.1 remote-as 12

no auto-summary

Setelah semua router dikonfigurasi sesuai petunjuk di atas kemudian lakukan verifikasi, kalau sudah sesuai dengan verifikasi di bawah ini berarti konfigurasi anda sudah benar.

veri 1

veri 2

veri 3

veri 4