Setelah sebelumnya mempelajari mengenai internal BGP, kini saatnya mengetahui permasalahan atau issue yang ada pada iBGP.

Pemasalahannya adalah ketika ada penambahan router baru semua router tersebut harus melakukan peers ke semua router, tentunya apabila banyak router yang terhubung akan merepotkan admin.

Untuk mengatasi hal tersebut ada berbagai cara, salah satunya dengan menjadikan salah satu routernya menjadi route reflector.

topologi

Pada lab kali ini R1 akan dijadikan sebagai route reflector, maka RR akan melakukan peers ke semua router dan semua router peersnya cukup ke RR saja.

Petunjuk Lab

1. Konfigurasikan IP pada topologi diatas.

2. Advertise semua IP ke RIP.

3. R1 dijadikan router reflectornya.

4. Router lain jadi route reflector client nya.

5. R1 sebagai RR melakukan peers ke semua router

6. Router lain, neighbor peersnya cukup ke RR saja.

Konfigurasikan router sebagai berikut :

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
network 1.0.0.0
network 12.0.0.0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1234
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 route-reflector-client
neighbor 3.3.3.3 remote-as 1234
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 route-reflector-client
neighbor 4.4.4.4 remote-as 1234
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 route-reflector-client
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
router rip
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback0
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
router rip
network 3.0.0.0
network 23.0.0.0
network 34.0.0.0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback0
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
network 4.0.0.0
network 34.0.0.0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
network 44.44.44.44 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 1234
neighbor 1.1.1.1 update-source Loopback0
no auto-summary

 

Verifikasi

r1

r3

Untuk pengetesan, advertise suatu route di salah satu router dan pastikan bisa di ping dari semua router. Misal sebagai berikut

loopback r4

Cek di semua router mengenai route yang di advertise oleh R4 ke BGP itu.

sh ip bgp

Lakukan ping ke semua router, pastikan semua loopbacknya bisa di ping dari semua router.

ping