Archive for Februari 17, 2013


Multi-protocol label switching (MPLS) adalah arsitektur network yang didefinisikan oleh IETF untuk memadukan mekanisme label swapping di layer 2 dengan routing di layer 3 untuk mempercepat pengiriman paket.

Pada proses forwarding, protokol ini menentukan forwarding berdasarkan label pada paket. Label yang pendek dan berukuran tetap mempercepat proses forwarding dan mempertinggi fleksibilitas pemilihan path. Hasil forwarding adalah network datagram yang bersifat lebih connection-oriented yaitu setiap virtual circuit harus disetup dengan protokol persinyalan sebelum transmisi (proses signaling).

Pada skenario topologi di bawah ini akan dibuat jaringan MPLS antara router PE 1 dan PE 2, dengan kabel serial sebagai jalur utama dan fast ethernet sebagai link backup.

topologi

Petunjuk lab

1. Lakukan konfigurasi IP bebas, untuk lebih mudahnya ikuti saja topologi di atas.

CE1A

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
clock rate 2000000

CE1B

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.10.6 255.255.255.0
clock rate 2000000

P1

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 24.24.24.1 255.255.255.0

P2

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.2 255.255.255.0
!
interface FastEthernet0/1
ip address 34.34.34.1 255.255.255.0

PE1

interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.0.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 12.12.12.1 255.255.255.0

2. Routing yang digunakan pada seluruh topologi di atas adalah OSPF area 0.

CE1A

router ospf 1
network 5.5.5.5 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0

CE1B

router ospf 1
network 6.6.6.6 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0

P1

router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 24.24.24.0 0.0.0.255 area 0

P2

router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 13.13.13.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0

PE1

router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 13.13.13.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0

PE2

router ospf 1
network 4.4.4.4 0.0.0.0 area 0
network 24.24.24.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0

3. Pada PE1 dan PE2 konfigurasikan routing BGP.

PE1

router bgp 1
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0

PE2

router bgp 1
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0

4. Aktifkan fungsi MPLS pada PE1, PE2, P1 dan P2.

Router P1

P1(config)#mpls ip

P1(config)#interface Serial0/0/0

P1(config-if)#mpls ip

P1(config)#interface Serial0/0/1

P1(config-if)#mpls ip

Router P2

P2(config)#mpls ip

P2(config)#interface FastEthernet0/0

P2(config-if)#mpls ip

P2(config)#interface FastEthernet0/1

P2(config-if)#mpls ip

Router PE1

PE1(config)#mpls ip

PE1(config)#interface Serial0/0/1

PE1(config-if)#mpls ip

PE1(config)#interface FastEthernet0/0

PE1(config-if)#mpls ip

Router PE2

PE2(config)#mpls ip

PE2(config)#interface Serial0/0/0

PE2(config-if)#mpls ip

PE2(config)#interface FastEthernet0/0

PE2(config-if)#mpls ip

5. Buat IP vrf pada PE1 dan PE2.

PE1

PE1(config)#ip vrf COSTUMER

PE1(config-vrf)#rd 1:1

PE1(config-vrf)#route target both 1:1

PE2

PE2(config)#ip vrf COSTUMER

PE2(config-vrf)#rd 1:1

PE2(config-vrf)#route target both 1:1

6. Masukkan IP vrf forwarding pada interface PE yang menuju CE.

PE1

PE1(config)#interface Serial0/0/0

PE1(config-if)#ip vrf forwarding customer

PE1(config-if)#ip address 192.168.0.2 255.255.255.0

PE2

PE2(config)#interface Serial0/0/1

PE2(config-if)#ip vrf forwarding customer

PE2(config-if)#ip address 192.168.10.5 255.255.255.0

7. Aktifkan fungsi Multiprotocol BGP.

PE1

PE1(config)#router bgp 1

PE1(config-router)#address-family vpnv4

PE1(config-router-af)#neighbor 4.4.4.4 activate

PE2

PE2(config)#router bgp 1

PE2(config-router)#address-family vpnv4

PE2(config-router-af)#neighbor 1.1.1.1 activate

8. Menambahkan routing PE-CE

PE1

PE1(config)#router ospf 100 vrf COSTUMER

PE1(config-router)#redistribute bgp 1 subnets

PE1(config-router)#network 192.168.0.0 0.0.0.255 area 0

PE1(config)#router bgp 1

PE1(config-router)#address-family ipv4 vrf COSTUMER

PE1(config-router-af)#redistribute ospf 100 vrf customer match internal external 1 external 2

PE2

PE2(config)#router ospf 100 vrf customer

PE2(config-router)#redistribute bgp 1 subnets

PE2(config-router)#network 192.168.10.0 0.0.0.255 area 0

PE2(config)#router bgp 1

PE2(config-router)#address-family ipv4 vrf customer

PE2(config-router-af)#redistribute ospf 100 vrf customer match internal external 1 external 2

9. Konfigurasikan default route pada router CE

Router CE1A

CE1A(config)#router ospf 1

CE1A(config-router)#network 0.0.0.0 255.255.255.255 area 0

Router CE1B

CE1B(config)#router ospf 1

CE1B(config-router)#network 0.0.0.0 255.255.255.255 area 0

9. Mengaktifkan Traffic Engineering.

Router P1

P1(config)#mpls traffic-eng tunnels

P1(config)#interface Serial0/0/0

P1(config-if)#mpls traffic-eng tunnels

P1(config)#interface Serial0/0/1

P1(config-if)#mpls traffic-eng tunnels

Router P2

P2(config)#mpls traffic-eng tunnels

P2(config)#interface FastEthernet0/0

P2(config-if)#mpls traffic-eng tunnels

P2(config)#interface FastEthernet0/1

P2(config-if)#mpls traffic-eng tunnels

Router PE1

PE1(config)#mpls traffic-eng tunnels

PE1(config)#interface Serial0/0/1

PE1(config-if)#mpls traffic-eng tunnels

PE1(config)#interface FastEthernet0/0

PE1(config-if)#mpls traffic-eng tunnels

Router PE2

PE2(config)#mpls traffic-eng tunnels

PE2(config)#interface Serial0/0/0

PE2(config-if)#mpls traffic-eng tunnels

PE2(config)#interface FastEthernet0/0

PE2(config-if)#mpls traffic-eng tunnels

10. Mengkonfigurasikan RSVP Bandwidth.

Router P1

P1(config)#interface Serial0/0/0

P1(config-if)#ip rsvp bandwidth 100 100

P1(config)#interface Serial0/0/1

P1(config-if)#ip rsvp bandwidth 100 100

Router P2

P2(config)#interface FastEthernet0/0

P2(config-if)#ip rsvp bandwidth 1000 1000

P2(config)#interface FastEthernet0/1

P2(config-if)#ip rsvp bandwidth 1000 1000

Router PE1

PE1(config)#interface Serial0/0/1

PE1(config-if)#ip rsvp bandwidth 100 100

PE1(config)#interface FastEthernet0/0

PE1(config-if)#ip rsvp bandwidth 1000 1000

Router PE2

PE2(config)#interface Serial0/0/0

PE2(config-if)#ip rsvp bandwidth 100 100

PE2(config)#interface FastEthernet0/0

PE2(config-if)#ip rsvp bandwidth 1000 1000

11. Membuat interface Tunnel pada Head-end Router PE1.

PE1(config)#interface Tunnel0

PE1(config-if)#ip unnumbered Loopback 0

PE1(config-if)#tunnel destination 4.4.4.4

PE1(config-if)#tunnel mode mpls traffic-eng

PE1(config-if)#tunnel mpls traffic-eng priority 1 1

PE1(config-if)#tunnel mpls traffic-eng bandwidth 100

PE1(config-if)#tunnel mpls traffic-eng path-option 1 explicit identifier 1

12. Mengaktifkan Tunnel jalur utama untuk OSPF.

PE1(config)#interface Tunnel0

PE1(config-if)#tunnel mpls traffic-eng autoroute announce

13. Mengaktifkan Path untuk jalur utama.

PE1(config)#interface Tunnel0

PE1(config-if)#tunnel mpls traffic-eng path-option 1 explicit identifier 1

14. Menentukan jalur untuk Tunnel jalur utama dan jalur kedua.

Router PE1

PE1(config)#ip explicit-path identifier 1

PE1(cfg-ip-expl-path)#next-address 12.12.12.2

PE1(cfg-ip-expl-path)#next-address 24.24.24.2

PE1(cfg-ip-expl-path)#next-address 4.4.4.4

PE1(config)#ip explicit-path identifier 2

PE1(cfg-ip-expl-path)#next-address 13.13.13.2

PE1(cfg-ip-expl-path)#next-address 34.34.34.2

PE1(cfg-ip-expl-path)#next-address 4.4.4.4

15. Mengaktifkan area OSPF untuk Traffic Engineering

Router P1

P1(config)#router ospf 1

P1(config-router)#mpls traffic-eng router-id Loopback0

P1(config-router)#mpls traffic-eng area 0

Router P2

P2(config)#router ospf 1

P2(config-router)#mpls traffic-eng router-id Loopback0

P2(config-router)#mpls traffic-eng area 0

Router PE1

PE1(config)#router ospf 1

PE1(config-router)#mpls traffic-eng router-id Loopback0

PE1(config-router)#mpls traffic-eng area 0

Router PE2

PE2(config)#router ospf 1

PE2(config-router)#mpls traffic-eng router-id Loopback0

PE2(config-router)#mpls traffic-eng area 0

Untuk konfigurasi lengkapnya bisa dilihat pada konfigurasi di bawah ini.

CE1A

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0

CE1B

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.6 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0

P1

mpls traffic-eng tunnels

!

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface Serial0/1
ip address 24.24.24.1 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 24.24.24.0 0.0.0.255 area 0

P2

mpls traffic-eng tunnels

!

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.2 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface FastEthernet0/1
ip address 34.34.34.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 13.13.13.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0

PE1

ip vrf COSTUMER
rd 1:1
route-target export 1:1
route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 4.4.4.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 1 explicit identifier 1
no routing dynamic
!
interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface Serial0/0
ip vrf forwarding COSTUMER
ip address 192.168.0.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 12.12.12.1 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
router ospf 100 vrf COSTUMER
log-adjacency-changes
redistribute bgp 1 subnets
network 192.168.0.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 13.13.13.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf COSTUMER
redistribute ospf 100 vrf COSTUMER match internal external 1 external 2
no synchronization
exit-address-family
!
ip explicit-path identifier 1 enable
next-address 12.12.12.2
next-address 24.24.24.2
next-address 4.4.4.4
!
ip explicit-path identifier 2 enable
next-address 13.13.13.2
next-address 34.34.34.2
next-address 4.4.4.4

PE2

ip vrf COSTUMER
rd 1:1
route-target export 1:1
route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.2 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface Serial0/0
ip address 24.24.24.2 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface Serial0/1
ip vrf forwarding COSTUMER
ip address 192.168.10.5 255.255.255.0
clock rate 2000000
!
router ospf 100 vrf COSTUMER
log-adjacency-changes
redistribute bgp 1 subnets
network 192.168.10.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 24.24.24.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf COSTUMER
redistribute ospf 100 vrf COSTUMER match internal external 1 external 2
no synchronization
exit-address-family

Lakukan verifikasi sebagai berikut

1. Ping dan traceroute dari PC1 ke PC2, pastikan trafik melalui jalur atas. Yaitu serial yang dijadikan jalur utama.

ping trace pc1 ke pc2

2. Pastikan interface tunnel sudah UP.

tunnels brief

3. Pada verifikasi di bawah terlihat status tunnel sudah UP dan trafik melalu jalur atas yaitu 12.12.12.2, 24.24.24.2

tunnel destination

4. Coba matikan main link yaitu jalur atas dengan mengetikkan perintah

PE2(config)#int s0/0

PE2(config-if)#shutdown

ping pc1 ke pc2 failover

5. Kemudian lakukan traceroute kembali ke PC2

trace pc1 ke pc2 failover

Terlihat jalur telah berpindah ke jalur backup yaitu jalur bawah (fast ethernet), dengan IP 13.13.13.2

Setelah mempelajari BGP Fail Over pada postingan sebelumnya, kini saatnya belajar BGP load balancing. Pada defaultnya, BGP hanya menggunakan 1 link saja untuk berkomunikasi.

Topologinya masih sama seperti sebelumnya.

topologi

Petunjuk lab

1. Konfigurasi IP dan routing bisa menggunakan seperti postingan sebelumnya.

2. Hapus konfigurasi attribute dari lab sebelumnya.

3. Konfigurasikan BGP maximum-path, digunakan agar BGP bisa menggunakan 2 jalur.

R1(config)#router bgp 10

R1(config-router)#maximum-paths 2

R1(config-router)#do clear ip bgp *

Lebih jelasnya konfigurasinya sebagai berikut, ini hasil ketika dilakukan show run pada R1.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 230
neighbor 13.13.13.3 remote-as 230
maximum-paths 2
no auto-summary
!
address-family nsap
maximum-paths 2
no synchronization
exit-address-family

Untuk konfigurasi R2, R3 dan R4 sama seperi postingan sebelumnya di BGP Fail Over

verifikasi

1

2

3

4

Lanjut ke lab berikutnya yaitu BGP Multihoming, kita akan mempelejari BGP redudancy, BGP Load Balancing, Mempelajari Attribute Weight, Local Preference, MED, AS-Path.

BGP Multihoming ada 2 tipe.

1. BGP dengan 2 link ke ISP sama (AS number ISPnya sama)

a. Mode Main – Backup.

b. Mode Load Sharing / Load Balancing.

2. BGP dengan 2 link ke ISP yang berbeda (AS number ISP beda)

a. Mode Main – Backup.

b. Mode Load Sharing / Load Balancing.

Topologinya sebagai berikut.

topologi

Petunjuk Lab

1. Setting IP pada tiap router, bisa menyesuaikan dengan artikel – artikel sebelumnya.

2. Misal R1 adalah router kantor pusat.

3. R2 dan R3 adalah Service Provider.

4. R4 adalah router di kantor cabang, yang akan kita gunakan sebagai tujuan.

5. Seperti pada topologi di atas, kantor pusat memiliki 2 link upstream, misal R2 di australia dan R3 di Jepang.

6. R1 eBGP peers ke R2 dan R3.

7. R2 dan R3 iBGP peers, serta eBGP peers ke R4.

8. Konfigurasikan Weight, MED, dan AS-Path.

Konfigurasi routernya adalah sebagai berikut.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 230
neighbor 13.13.13.3 remote-as 230
no auto-summary

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 230
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 10
neighbor 23.23.23.3 remote-as 230
neighbor 24.24.24.4 remote-as 40
no auto-summary

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 230
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 13.13.13.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 13.13.13.1 remote-as 10
neighbor 23.23.23.2 remote-as 230
neighbor 34.34.34.4 remote-as 40
no auto-summary

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 40
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 24.24.24.2 remote-as 230
neighbor 34.34.34.3 remote-as 230
no auto-summary

Verifikasi

1

2

Dari 2 verifikasi di atas dapat disimpulkan walaupun sudah disambungkan dengan 2 link, namun tetap hanya 1 link saja yang digunakan. BGP defaultnya hanya menggunakan 1 link saja.

Sekarang lakukan shutdown R1 Fa0/0 (12.12.12.1/24) sehingga paket tidak lagi melalui R2. Hal tersebut untuk memastikan bahwa kedua linknya berfungsi dengan baik, sehingga ketika main link down dapat dilakukan fungsi  backup pada link yang ke R3. Atau yang sering kita sebut dengan failover.

3

4

Sipp, failover berhasil dilakukan dan linknya berpindah lewat R3.

Lalu kita tes kembali dengan menghidupkan kembali main linknya, yaitu Fa0/0 pada R1. Harapannya jika main link UP link akan kembali ke kondisi semula.

R1(config-if)#int fa0/0

R1(config-if)#no sh

Lakukan verifikasi

5

Wah ternyata belum sesuai harapan, linknya masih menggunakan link back-up. Padahal main linknya sudah UP.

Untuk memastikan agar link ke R2 menjadi main link, kita konfigurasikan attribute weight. Karena pada BGP default tidak bisa melakukannya.

6

Sealin weight, kita juga bisa menggunakan Local Preference. Perbedaannya kalau pada weight pengaruhnya hanya pada router yang dikonfigurasikan weight, sedangkan kalau menggunakan local preference pengaruhnya ke semua router dalam internal BGP.
Berikut pemilihan route BGP berdasarkan atribut nya, mulai dari atas dulu, kalau nilai atributnya sama, kemudian menurun ke atribut bawahnya.
  • Weight, yang lebih tinggi yang dipilih (Cisco Proprietary)
  • Local Preference, yang lebih tinggi yang dipilih
  • Locally Originated, route berasal dari internal BGP
  • AS-Path, jalur AS terpendek yang dipilih
  • Origin (IGP, EGP, ?) route yang berasal dari eBGP dan iBGP lebih dipilih daripada route yang berasal dari EGP ataupun IGP yang diredistribute ke BGP
  • MED, nilai metric yang paling rendah yang dipilih
 
Cek kembali setelah dikonfigurasikan weight.
7
Selain mengatur trafik keluar, kita juga bisa mengatur trafik yang datang ke AS kita.
Konfigurasikan di R1, agar trafik menuju ke network internal kita datangnya melalui R3 yang diset nilai metric lebih rendah (100) dibanding R2 (110)

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 230
neighbor 12.12.12.2 route-map WEIGHT in
neighbor 12.12.12.2 route-map AS-PREPEND out
neighbor 13.13.13.3 remote-as 230
no auto-summary
!
ip access-list standard LAN
permit 1.1.1.1
!
route-map WEIGHT permit 10
set weight 100
!
route-map R2MED permit 10
match ip address LAN
set metric 110
!
route-map R3MED permit 10
match ip address LAN
set metric 100

verifikasi di R3 ke network internal R1 (1.1.1.1)
8
9
11
Seperti yang terlihat di atas dari R2 (AS 230) apabila ingin ke R1 (AS 10) akan melalui R3 dulu.
Selain menggunakan attribute MED, kita juga bisa menggunakan attribute AS-Path.
as-path
Lakukan verifikasi,
12
13

Apabila pada postingan sebelumnya kita menerapkan load balancing pada ISP yang sama, kali ini kita akan mencoba load balancing pada ISP yang berbeda. Artinya kedua ISP tersebut memiliki AS number yang berbeda.

Kita juga akan mempelajari agar pembagian trafik load balancing berjalan dengan semestinya sesuai bandwidth yang dimiliki masing – masing link. Topologinya sebagai berikut.

topologi

Petunjuk Lab

1. Masih menggunakan pengalamatan IP pada konfigurasi sebelumnya.

2. Hapus konfigurasi IGP dan BGP pada semua router.

3. Konfigurasikan eBGP pada semua router.

4. Konfigurasikan BGP maximum-path, bestpath as-path multipath-relax agar bisa load sharing.

5. Konfigurasikan dmzlink-bw agar load sharing bisa menyesuaikan kapasitas bandwidthnya.

Konfigurasi masing – masing routernya bisa dilihat di bawah ini, ini merupakan hasil akhir setelah dilakukan konfigurasi secara keseluruhan.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
bandwidth 100
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
bandwidth 200
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
bgp bestpath as-path multipath-relax
bgp dmzlink-bw
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 20
neighbor 12.12.12.2 dmzlink-bw
neighbor 13.13.13.3 remote-as 30
neighbor 13.13.13.3 dmzlink-bw
maximum-paths 2
no auto-summary
!
address-family nsap
maximum-paths 2
no synchronization
exit-address-family

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
router bgp 20
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 10
neighbor 23.23.23.3 remote-as 30
neighbor 24.24.24.4 remote-as 40
no auto-summary

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
router bgp 30
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 13.13.13.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 13.13.13.1 remote-as 10
neighbor 23.23.23.2 remote-as 20
neighbor 34.34.34.4 remote-as 40
no auto-summary

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 40
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 24.24.24.2 remote-as 20
neighbor 34.34.34.3 remote-as 30
no auto-summary

Verifikasi sudah ditambahkan “maximum-path 2”, namun belum ditambahkan “bgp bestpath as-path multipath-relax”

1

2

3

Terlihat gambar di atas belum terjadi load balancing, hanya 1 link saja yg berfungsi.

Kemudian setelah dikonfigurasikan “bgp bestpath as-path multipath-relax” di router bgp 10

4 sudah load sharing

Dari verifikasi di atas dapat kita lihat load sharing telah berhasil dilakukan dengan sukses :D. Namun permasalahannya adalah ketika kedua link memiliki kapasitas bandwidth yg berbeda, maka apa yang terjadi pada proses load balancing itu.

5 bandwidth beda

Ternyata traffic share countnya masih 1:1, padahal bandwidth kedua link tersebut berbeda. Tentunya hal tersebut bisa menjadi problem, terutama apabila tiap – tiap link memiliki selisih bandwidth yg cukup jauh. Untuk mengatasi hal tersebut tambahkan konfigurasi sebagai berikut.

dmz

7 prbandingan load share baik

Terlihat bahwa load balancingnya sudah dalam perbandingan yang baik. Fa0/1 akan lebih sering dipilih untuk mengirimkan trafik, baru ketika link Fa0/1 penuh, link Fa0/0 akan digunakan untuk membantu pengiriman trafik. Sehingga kedua link tersebut bisa digunakan sesuai kemampuannya.

8

Tujuan lab kali ini yaitu mengenal penggunaan BGP REGEX untu keperluan mencari / memfilter suatu router yang diinginkan.

Caranya dengan menggunakan internet yang memiliki tabel BGP yang sangat banyak.

Petunjuk lab

1. Buku web BGP Looking Glasses

2 . Telnet ke salah satu IP server di BGP Looking Glasses

web

3. Setelah di klik pada salah satu link akan muncul dialog box untuk melakukan telnet

telnet

4. Kita akan dibawa masuk ke server setelah telnet berhasil dilakukan, tampilannya seperti di bawah ini.

masuk server

5. Cek BGP pada server tersebut

sh ip bgp

6. Gunakan regexp untuk menampilkan route yang hanya dari AS 680

regexp 680

7. Gunakan regexp untuk menampikan route yg berasal dari AS 680 serta route lain di belakangnya

regexp 680_

8. Gunakan regexp untuk menampilkan semua route yang berasal dari AS 6461

regexp 6461

9. Gunakan regexp untuk menampilkan route yang berasal dari internal BGP

regexp ^$

10. Gunakan regexp untuk menampilkan route yang melewati AS 4725

regexp _4725_