MPLS pada dasarnya terdiri dari 3 jenis router :

  1. Router P (Provide)
  • Terdapat dalam MPLS Domain, P router terhubung dengan router-router lain yang dimiliki service provider
  • Pada jaringan MPLS yang tidak terlalu besar terkadang tidak terdapat P router didalamnya untuk menghemat biaya

2. Router PE (Provider Edge)

  • Merupakan router yang terhubung langsung dengan router customer dan juga sekaligus dengan router service provider
  • Menjembatani antara network berbasis IP dengan network berbasis MPLS
  • Memberikan pelabelan pada paket IP yang masuk ke dalam MPLS Domain
  • Melepas pelabelan pada paket yang akan keluar dari MPLS Domain
  • PE Router ini sifatnya harus ada pada setiap jaringan MPLS

3. Router CE (Customer Edge)

  • Merupakan router yang terdapat di sisi customer
  • Pada router CE ini tidak terdapat konfigurasi MPLS apapun
  • Konfigurasi routing biasa, bisa static atau dynamic seperti OSPF / EIGRP

Karena dalam jaringan MPLS Backbone hanya ada router P dan router PE, maka model jaringan MPLS yang sederhana dapat berbentuk seperti pada topologi di bawah ini.

topologi

Adapun tahapan konfigurasinya adalah sebagai berikut :

1. Pasang semua IP address pada semua router

Router PE1

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252

Router P

interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1
ip address 192.168.20.1 255.255.255.252
clock rate 2000000

Router PE2

interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252

2. Aktifkan routing dynamic

Agar semua IP router dapat saling berkomunikasi kita perlu mengkonfigurasikan dynamic routing. Pada jaringan backbone service provider biasanya sering menggunakan OSPF. Oleh sebab itu kali ini kita akan menggunakan dynamic routing OSPF pada lab kali ini.

Router PE1

router ospf 1
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0

Router P

router ospf 1
network 10.10.10.10 0.0.0.0 area 0
network 192.168.10.2 0.0.0.0 area 0
network 192.168.20.1 0.0.0.0 area 0

Router PE2

router ospf 1
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0

3. Aktifkan BGP

Untuk melewatkan informasi vrf, vpn, routing kita memerlukan multi protocol BGP, maka dari itu perlu diaktifkan routing BGP di kedua router PE.

PE1

router bgp 65000
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0

PE2

router bgp 65000
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0

4. Aktifkan MPLS

Konfigurasikan fungsi MPLS di semua interface router PE1 P dan PE2 yang saling terhubung, hal ini bertujuan untuk mengaktifkan fitur MPLS pada router.

PE1

mpls ip
interface Serial0/0
mpls ip

P

mpls ip
interface Serial0/0
mpls ip

!

mpls ip
interface Serial0/1
mpls ip

PE2

mpls ip
interface Serial0/0
mpls ip

Verifikasi

Ping ke semua loopback router, pastikan semua  IP loopback router bisa di ping.

ping pe1

Cek peering routing BGP nya dengan perintah Show ip bgp summary

bgp summ pe2

bgp summ

Show mpls forwarding-table digunakan untuk memastikan apakah mpls sudah berfungsi dengan baik atau belum.

mpls pe1

mpls pe2

 

Hasil show run nya adalah sebagai berikut.

Router PE1

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.252
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.252
!
router ospf 1
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary

 

Router PE2

interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.5 255.255.255.252
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.0.5 255.255.255.252
!
router ospf 1
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0

router bgp 65000
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary

 

Router P

interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface Serial0/1
ip address 192.168.20.1 255.255.255.252
mpls ip
clock rate 2000000
!
router ospf 1
network 10.10.10.10 0.0.0.0 area 0
network 192.168.10.2 0.0.0.0 area 0
network 192.168.20.1 0.0.0.0 area 0