Pada jaringan MPLS bisa difungsikan berbagai macam routing protokol, pada postingan sebelumnya telah kita pelajari tentang static routing. Kali ini kita akan mempelajari routing RIP pada MPLS, caranya dengan mengadvertise routing RIP ke BGP yg ada di jaringan MPLS.

Masih menggunakan topologi yang sama dengan artikel sebelumnya.

topologi

Petunjuk lab

1. Untuk MPLS backbone masih menggunakan topologi dan konfigurasi pada artikel sebelumnya yaitu MPLS VPN, silahkan lihat disini

2. Konfigurasi routing RIP pada PE1 dan PE2, lalu redistribute ke BGP yg sudah dikonfigurasi sebelumnya.

Router PE1

router rip
version 2
!
address-family ipv4 vrf bca.kiri
redistribute bgp 65000 metric transparent        (segala routing protokol lain yg di redistribusi ke RIP, metriknya akan dianggap sebagai metrik danri routing RIP)
network 192.168.0.0

!

router bgp 65000

address-family ipv4 vrf bca.kiri
redistribute rip            (mendistribusi routing RIP ke BGP)

Router PE2

router rip
version 2
!
address-family ipv4 vrf bca.kanan
redistribute bgp 65000 metric transparent
network 192.168.0.0

!

router bgp 65000

address-family ipv4 vrf bca.kanan
redistribute rip

3. Konfigurasi IP addess dan routing RIP pada router BCA.KIRI dan BCA.KANAN

Router 6 BCA.KIRI

interface Loopback0
ip address 6.6.6.6 255.255.255.255

router rip
version 2
network 0.0.0.0
no auto-summary

Router 7 BCA.KANAN

interface Loopback0
ip address 7.7.7.7 255.255.255.255

router rip
version 2
network 0.0.0.0
no auto-summary

Verifikasi

ping ke PE1 , PE2, BCA kiri, BCA kanan, dan loopbacknya

ping r6

Traceroute dan liat routing tabelnya.

tracer r7

Cek interfave VRF yang diset di router PE1 dan PE2 apakah sudah UP atau belum.

pe1 vrf

pe2 vrf

Cek MP BGPnya, dengan mengetik command seperti di bawah ini.

pe1

Iklan