Apabila pada artikel sebelumnya hanya membahas dan mengkonfigurasi router pada P (provider) dan PE (provider edge), kini saatnya mempelajari konfigurasi yang ada di CE (customer edge). Masih menggunakan topologi pada arikel sebelumnya.

topologi

Petunjuk lab

1. Masih menggunakan topologi pada artikel sebelumnya yaitu MPLS VPN, silahkan lihat disini

2. Konfigurasi static route pad PE1 dan PE2, lalu redistribute ke BGP yg sudah dikonfigurasi sebelumnya

Router PE1

PE1(config)#ip route vrf bri.kiri 10.0.0.1 255.255.255.255 192.168.0.2

PE1(config)#router bgp 65000

address-family ipv4 vrf bri.kiri           (untuk mengkonfigurasi sesi routing yg menggunakan standar IPv4 seperti bgp)
redistribute static                                     (memasukkan static routing ke routing bgp)
redistribute connected                           (memasukkan network yg terhubung langsung atau directly connected ke bgp)

Router PE2

PE2(config)#ip route vrf bri.kanan 10.0.0.2 255.255.255.255 192.168.0.6

PE2(config)#router bgp 65000

address-family ipv4 vrf bri.kanan
redistribute static
redistribute connected

3. Konfigurasi IP addess pada router BRI.KIRI dan BRI.KANAN

Router4 BRI.KIRI

interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1            (konfigurasi routing static)

Router5 BRI.KANAN

interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.0.5

Verifikasi

lakukan test ping ke IP loopback router CE dan vrf router PE.

ping r5

lakukan traceroute dari R5 ke R4, terlihat trafik melalui jalur MPLS.

r4 trace n sh ip route

Konfigurasi lengkap dari router bisa dilihat di bawah ini.

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kiri
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf bca.kiri
no synchronization
exit-address-family
!
ip route vrf bri.kiri 10.0.0.1 255.255.255.255 192.168.0.2

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kanan
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf bca.kanan
no synchronization
exit-address-family
!
ip route vrf bri.kanan 10.0.0.2 255.255.255.255 192.168.0.6

Router P

interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface Serial0/1
ip address 192.168.20.1 255.255.255.252
mpls ip
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 10.10.10.10 0.0.0.0 area 0
network 192.168.10.2 0.0.0.0 area 0
network 192.168.20.1 0.0.0.0 area 0

Router 4

interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1

Router 5

interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.0.5