Setelah belajar routing static dan RIP pada jaringan MPLS VPN, kini saatnya belajar tentang EIGRP. EIGRP merupakan routing protokol yang hanya support pada perangkat cisco saja, jd bila ingin digunakan dengan perangkat lain harus di redistribute ke routing protokol yg bersifat open misalnya BGP.

Masih menggunakan topologi sebelumnya, kita akan bermain – main di router BRI.

topologi

Petunjuk lab

1. Untuk MPLS backbone masih menggunakan topologi dan konfigurasi pada artikel sebelumnya yaitu MPLS VPN, silahkan lihat disini

2. Konfigurasi routing EIGRP pada PE1 dan PE2, lalu redistribute ke BGP yg sudah dikonfigurasi sebelumnya.

Router PE1

router eigrp 65000
no auto-summary
address-family ipv4 vrf bri.kiri
redistribute bgp 65000 metric 1 1 1 1 1    (agar metric dari bgp dapat dikenail oleh eigrp yg berdasarkan 5 komponenen, yaitu bandwidth, delay, reliability, load, MTU)
network 192.168.0.0
autonomous-system 100
!
router bgp 65000
address-family ipv4 vrf bri.kiri
redistribute eigrp 100                (routing protocol dari sisi CE di redistribute ke bgp yg ada di PE)

Router PE2

router eigrp 65000
no auto-summary
address-family ipv4 vrf bri.kanan
redistribute bgp 65000 metric 1 1 1 1 1
network 192.168.0.0
autonomous-system 100
!
router bgp 65000
address-family ipv4 vrf bri.kanan
redistribute eigrp 100

3. Konfigurasi IP addess dan routing EIGRP pada router BRI.KIRI dan BRI.KANAN

R4 BRI KIRI

router eigrp 100
network 0.0.0.0
no auto-summary

R5 BRI KANAN

router eigrp 100
network 0.0.0.0
no auto-summary

Verifikasi

Lakukan ping ke ip loopback R4 dan R5

ping r4

Lalu lakukan trace ke IP loopbacknya, terlihat melewati jalur MPLS.

trace r5

Lihat routing tabelnya, terlihat sudah menggunakan routing EIGRP yang bersimbol “D” pada routing tabel.

sh ip route r4

Apabila dilakukan show run pada masing – masing router akan terlihat seperti ini.

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 65000
no auto-summary
!
address-family ipv4 vrf bri.kiri
redistribute bgp 65000 metric 1 1 1 1 1
network 192.168.0.0
auto-summary
autonomous-system 100
exit-address-family
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kiri
redistribute eigrp 100
no synchronization
exit-address-family

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1

interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router eigrp 65000
no auto-summary
!
address-family ipv4 vrf bri.kanan
redistribute bgp 65000 metric 1 1 1 1 1
network 192.168.0.0
auto-summary
autonomous-system 100
exit-address-family
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kanan
redistribute eigrp 100
no synchronization
exit-address-family

R4 BRi KIRI

interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
network 0.0.0.0
no auto-summary

R5 BRI KANAN

interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
network 0.0.0.0
no auto-summary