Setelah belajar berbagai konfigurasi pada MPLS dengan berbahgai macam variasi routing protocol, kini saatnya untuk membuat backup link pada jaringan MPLS. Konfigurasinya seperti di bawah ini.
topologi
Kondisi awal, interface serial antara Router CE1_BRI dan Router CE2_BRI dalam kondisi shutdown, sehingga dari Router CE1_BRI untuk menuju ke Router CE2_BRI akan menggunakan link MPLS nya. Selanjutnya ketika interface serial nya telah aktif kembali maka Router CE1_BRI akan langsung menuju Router CE2_BRI tanpa melalui MPLS nya terlebih dahulu. Hal ini disebabkan oleh :
  • Directly Connected (AD = 0) memiliki AD yang lebih rendah dibandingkan dengan OSPF (AD = 100)

Petunjuk Lab

1. Menggunakan konfigurasi pada postingan sebelumnya, MPLS VPN OSPF, silahkan lihat disini.

2. Set konfigurasi tambahan untuk koneksi serial antara R4 dan R5.

Router 4

interface Loopback0
ip address 4.4.4.4 255.255.255.255

interface Serial0/0
ip address 45.45.45.4 255.255.255.0

router ospf 1
network 0.0.0.0 255.255.255.255 area 0

Router 5

interface Loopback0
ip address 5.5.5.5 255.255.255.255

interface Serial0/0
ip address 45.45.45.5 255.255.255.0

router ospf 1
network 0.0.0.0 255.255.255.255 area 0

Lakukan traceroute dari R4 ke R5, pada gambar di bawah ini terlihat trafik tidak melalui jalur MPLS malah langsung melalui interface serial. Hal ini tentunya tidak diharapkan, karena serial sebenarnya hanya jalur backup saja.

before

 

 

3. Konfigurasikan shamlink agar trafik melalui jalur MPLS

Router PE1

interface Loopback 100
ip vrf forwarding bri.kiri
ip address 100.100.100.4 255.255.255.255

router ospf 100 vrf bri.kiri
router-id 100.100.100.4       (mengkonfigurasi identitas routes ospf, yg digunakan sebagai IP tujuan router lawan)
area 0 sham-link 100.100.100.4 100.100.100.5

(area 0 = area ospf yg digunakan untuk sham-link) (100.100.100.4 = IP sumber, 100.100.100.5 = IP tujuan)

router bgp 65000
network 100.100.100.4 mask 255.255.255.255

Router PE2

interface Loopback 100
ip vrf forwarding bri.kiri
ip address 100.100.100.5 255.255.255.255

router ospf 100 vrf bri.kiri
router-id 100.100.100.5
area 0 sham-link 100.100.100.5 100.100.100.4

router bgp 65000
network 100.100.100.5 mask 255.255.255.255

 

4. Konfigurasikan nilai cost pada interface serial R4 dan R5

Router R4

interface Serial0/0
ip address 45.45.45.4 255.255.255.0
ip ospf cost 20000    (memberi nilai cost ospf yg kita tentukan sendiri pada interface) 

Router R5

interface Serial0/0
ip address 45.45.45.5 255.255.255.0
ip ospf cost 20000

Lakukan  “do clear ip os process” untuk mereset routing ospf yang sedang berjalan.

Kemudian lakukan verifikasi dengan melakukan traceroute lagi dari IP loopback R4 ke R5 dan sebaliknya.

after

r4

 

Dari 2 gambar di atas terlihat trafik sudah melalui jalur MPLS dengan benar, sesuai yang diharapkan.

Hasil show run nya adalah sebagai berikut.

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface Loopback100
ip vrf forwarding bri.kiri
ip address 100.100.100.4 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 100 vrf bri.kiri
router-id 100.100.100.4
log-adjacency-changes
area 0 sham-link 100.100.100.4 100.100.100.5
redistribute bgp 65000 subnets
network 192.168.0.1 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kiri
redistribute ospf 100 vrf bri.kiri match internal external 1 external 2
no synchronization
network 100.100.100.4 mask 255.255.255.255
exit-address-family
!
address-family ipv4 vrf bca.kiri
no synchronization
exit-address-family

 

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface Loopback100
ip vrf forwarding bri.kanan
ip address 100.100.100.5 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 100 vrf bri.kanan
router-id 100.100.100.5
log-adjacency-changes
area 0 sham-link 100.100.100.5 100.100.100.4
redistribute bgp 65000 subnets
network 192.168.0.5 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kanan
redistribute ospf 100 vrf bri.kanan match internal external 1 external 2
no synchronization
network 100.100.100.5 mask 255.255.255.255
exit-address-family
!
address-family ipv4 vrf bca.kanan
no synchronization
exit-address-family

 

Router R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 45.45.45.4 255.255.255.0
ip ospf cost 20000
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0

 

Router R5

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 45.45.45.5 255.255.255.0
ip ospf cost 20000
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0