Category: BGP


Kita sudah mempelajari berbagai macam routing pada MPLS, mulai dari static hingga dinamic (RIP dan EIGRP). Masih ada routing dinamic yaitu BGP. Pada lab kali ini kita akan mencoba menerapkan routing BGP pada jaringan MPLS.

Topologinya ada di bawah ini, kita akan menerapkan BGP pada BANK BCA.

topologi

Petunjuk LAB

1. Untuk MPLS backbone masih menggunakan topologi dan konfigurasi pada artikel sebelumnya yaitu MPLS VPN, silahkan lihat disini

 

2. Konfigurasi routing BGP pada PE1 dan PE2, lalu redistribute ke BGP yg sudah dikonfigurasi sebelumnya.

Router PE1

router bgp 65000

address-family ipv4 vrf bca.kiri
neighbor 192.168.0.2 remote-as 100 (Memasukkan IP PE2 ke dalam routing tabel BGP router PE1)
neighbor 192.168.0.2 activate              (Untuk mengaktifkan pertukaran informasi dengan protocol BGP lawan)
neighbor 192.168.0.2 as-override      (Untuk mencegah routing loop dari router yg sama2 mengaktifkan vpn dan memliki AS number yg sama)
network 192.168.0.0 mask 255.255.255.252 (Memasukkan alamat network yg akan digunakan untuk berkomunikasi dari PE1 ke PE2 ke dalam routing tabel BGP)

 

Router PE2

router bgp 65000

address-family ipv4 vrf bca.kanan
neighbor 192.168.0.6 remote-as 100
neighbor 192.168.0.6 activate
neighbor 192.168.0.6 as-override
network 192.168.0.4 mask 255.255.255.252

 

3. Konfigurasi IP addess dan routing BGP pada router BCA.KIRI dan BCA.KANAN

R6 BCA KIRI

router bgp 100
network 6.6.6.6 mask 255.255.255.255
network 192.168.0.0 mask 255.255.255.252
neighbor 192.168.0.1 remote-as 65000

 

R7 BCA KANAN

router bgp 100
network 7.7.7.7 mask 255.255.255.255
network 192.168.0.4 mask 255.255.255.252
neighbor 192.168.0.5 remote-as 65000

 

Verifikasi

Lakukan ping ke interface PE yg terhubung ke bank  BCA, dan loopback semua router BCA

ping r7

Lakukan traceroute untuk memastikan trafik sudah melalui jalur yg benar dan melalui jalur MPLS.

tracer r6

terlihat trafik dari R6 ke R7, melalui PE1 yg merupakan jalur MPLS kemudian langsung ke PE2 yg menggunakan routing BGP dengan AS number 65000

tracer r7

Cek routing tabelnya pastikan sudah menggunakan routing BGP yang bersimbol “B” pada routing tabel.

sh ip route r6

 

Hasil show run dari lab kali ini adalah sebagai berikut.

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family

address-family ipv4 vrf bca.kiri
neighbor 192.168.0.2 remote-as 100
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 as-override
no synchronization
network 192.168.0.0 mask 255.255.255.252
exit-address-family

 

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf bca.kanan
neighbor 192.168.0.6 remote-as 100
neighbor 192.168.0.6 activate
neighbor 192.168.0.6 as-override
no synchronization
network 192.168.0.4 mask 255.255.255.252
exit-address-family

 

Router R6 BCA KIRI

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 6.6.6.6 mask 255.255.255.255
network 192.168.0.0 mask 255.255.255.252
neighbor 192.168.0.1 remote-as 65000
no auto-summary

 

Router 7 BCA KANAN

interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 7.7.7.7 mask 255.255.255.255
network 192.168.0.4 mask 255.255.255.252
neighbor 192.168.0.5 remote-as 65000

Iklan

Setelah mempelajari BGP Fail Over pada postingan sebelumnya, kini saatnya belajar BGP load balancing. Pada defaultnya, BGP hanya menggunakan 1 link saja untuk berkomunikasi.

Topologinya masih sama seperti sebelumnya.

topologi

Petunjuk lab

1. Konfigurasi IP dan routing bisa menggunakan seperti postingan sebelumnya.

2. Hapus konfigurasi attribute dari lab sebelumnya.

3. Konfigurasikan BGP maximum-path, digunakan agar BGP bisa menggunakan 2 jalur.

R1(config)#router bgp 10

R1(config-router)#maximum-paths 2

R1(config-router)#do clear ip bgp *

Lebih jelasnya konfigurasinya sebagai berikut, ini hasil ketika dilakukan show run pada R1.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 230
neighbor 13.13.13.3 remote-as 230
maximum-paths 2
no auto-summary
!
address-family nsap
maximum-paths 2
no synchronization
exit-address-family

Untuk konfigurasi R2, R3 dan R4 sama seperi postingan sebelumnya di BGP Fail Over

verifikasi

1

2

3

4

Lanjut ke lab berikutnya yaitu BGP Multihoming, kita akan mempelejari BGP redudancy, BGP Load Balancing, Mempelajari Attribute Weight, Local Preference, MED, AS-Path.

BGP Multihoming ada 2 tipe.

1. BGP dengan 2 link ke ISP sama (AS number ISPnya sama)

a. Mode Main – Backup.

b. Mode Load Sharing / Load Balancing.

2. BGP dengan 2 link ke ISP yang berbeda (AS number ISP beda)

a. Mode Main – Backup.

b. Mode Load Sharing / Load Balancing.

Topologinya sebagai berikut.

topologi

Petunjuk Lab

1. Setting IP pada tiap router, bisa menyesuaikan dengan artikel – artikel sebelumnya.

2. Misal R1 adalah router kantor pusat.

3. R2 dan R3 adalah Service Provider.

4. R4 adalah router di kantor cabang, yang akan kita gunakan sebagai tujuan.

5. Seperti pada topologi di atas, kantor pusat memiliki 2 link upstream, misal R2 di australia dan R3 di Jepang.

6. R1 eBGP peers ke R2 dan R3.

7. R2 dan R3 iBGP peers, serta eBGP peers ke R4.

8. Konfigurasikan Weight, MED, dan AS-Path.

Konfigurasi routernya adalah sebagai berikut.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 230
neighbor 13.13.13.3 remote-as 230
no auto-summary

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 230
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 10
neighbor 23.23.23.3 remote-as 230
neighbor 24.24.24.4 remote-as 40
no auto-summary

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 230
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 13.13.13.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 13.13.13.1 remote-as 10
neighbor 23.23.23.2 remote-as 230
neighbor 34.34.34.4 remote-as 40
no auto-summary

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 40
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 24.24.24.2 remote-as 230
neighbor 34.34.34.3 remote-as 230
no auto-summary

Verifikasi

1

2

Dari 2 verifikasi di atas dapat disimpulkan walaupun sudah disambungkan dengan 2 link, namun tetap hanya 1 link saja yang digunakan. BGP defaultnya hanya menggunakan 1 link saja.

Sekarang lakukan shutdown R1 Fa0/0 (12.12.12.1/24) sehingga paket tidak lagi melalui R2. Hal tersebut untuk memastikan bahwa kedua linknya berfungsi dengan baik, sehingga ketika main link down dapat dilakukan fungsi  backup pada link yang ke R3. Atau yang sering kita sebut dengan failover.

3

4

Sipp, failover berhasil dilakukan dan linknya berpindah lewat R3.

Lalu kita tes kembali dengan menghidupkan kembali main linknya, yaitu Fa0/0 pada R1. Harapannya jika main link UP link akan kembali ke kondisi semula.

R1(config-if)#int fa0/0

R1(config-if)#no sh

Lakukan verifikasi

5

Wah ternyata belum sesuai harapan, linknya masih menggunakan link back-up. Padahal main linknya sudah UP.

Untuk memastikan agar link ke R2 menjadi main link, kita konfigurasikan attribute weight. Karena pada BGP default tidak bisa melakukannya.

6

Sealin weight, kita juga bisa menggunakan Local Preference. Perbedaannya kalau pada weight pengaruhnya hanya pada router yang dikonfigurasikan weight, sedangkan kalau menggunakan local preference pengaruhnya ke semua router dalam internal BGP.
Berikut pemilihan route BGP berdasarkan atribut nya, mulai dari atas dulu, kalau nilai atributnya sama, kemudian menurun ke atribut bawahnya.
  • Weight, yang lebih tinggi yang dipilih (Cisco Proprietary)
  • Local Preference, yang lebih tinggi yang dipilih
  • Locally Originated, route berasal dari internal BGP
  • AS-Path, jalur AS terpendek yang dipilih
  • Origin (IGP, EGP, ?) route yang berasal dari eBGP dan iBGP lebih dipilih daripada route yang berasal dari EGP ataupun IGP yang diredistribute ke BGP
  • MED, nilai metric yang paling rendah yang dipilih
 
Cek kembali setelah dikonfigurasikan weight.
7
Selain mengatur trafik keluar, kita juga bisa mengatur trafik yang datang ke AS kita.
Konfigurasikan di R1, agar trafik menuju ke network internal kita datangnya melalui R3 yang diset nilai metric lebih rendah (100) dibanding R2 (110)

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 230
neighbor 12.12.12.2 route-map WEIGHT in
neighbor 12.12.12.2 route-map AS-PREPEND out
neighbor 13.13.13.3 remote-as 230
no auto-summary
!
ip access-list standard LAN
permit 1.1.1.1
!
route-map WEIGHT permit 10
set weight 100
!
route-map R2MED permit 10
match ip address LAN
set metric 110
!
route-map R3MED permit 10
match ip address LAN
set metric 100

verifikasi di R3 ke network internal R1 (1.1.1.1)
8
9
11
Seperti yang terlihat di atas dari R2 (AS 230) apabila ingin ke R1 (AS 10) akan melalui R3 dulu.
Selain menggunakan attribute MED, kita juga bisa menggunakan attribute AS-Path.
as-path
Lakukan verifikasi,
12
13

Apabila pada postingan sebelumnya kita menerapkan load balancing pada ISP yang sama, kali ini kita akan mencoba load balancing pada ISP yang berbeda. Artinya kedua ISP tersebut memiliki AS number yang berbeda.

Kita juga akan mempelajari agar pembagian trafik load balancing berjalan dengan semestinya sesuai bandwidth yang dimiliki masing – masing link. Topologinya sebagai berikut.

topologi

Petunjuk Lab

1. Masih menggunakan pengalamatan IP pada konfigurasi sebelumnya.

2. Hapus konfigurasi IGP dan BGP pada semua router.

3. Konfigurasikan eBGP pada semua router.

4. Konfigurasikan BGP maximum-path, bestpath as-path multipath-relax agar bisa load sharing.

5. Konfigurasikan dmzlink-bw agar load sharing bisa menyesuaikan kapasitas bandwidthnya.

Konfigurasi masing – masing routernya bisa dilihat di bawah ini, ini merupakan hasil akhir setelah dilakukan konfigurasi secara keseluruhan.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
bandwidth 100
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
bandwidth 200
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp log-neighbor-changes
bgp bestpath as-path multipath-relax
bgp dmzlink-bw
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 13.13.13.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 20
neighbor 12.12.12.2 dmzlink-bw
neighbor 13.13.13.3 remote-as 30
neighbor 13.13.13.3 dmzlink-bw
maximum-paths 2
no auto-summary
!
address-family nsap
maximum-paths 2
no synchronization
exit-address-family

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
router bgp 20
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 10
neighbor 23.23.23.3 remote-as 30
neighbor 24.24.24.4 remote-as 40
no auto-summary

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
router bgp 30
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 13.13.13.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 13.13.13.1 remote-as 10
neighbor 23.23.23.2 remote-as 20
neighbor 34.34.34.4 remote-as 40
no auto-summary

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 40
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 34.34.34.0 mask 255.255.255.0
neighbor 24.24.24.2 remote-as 20
neighbor 34.34.34.3 remote-as 30
no auto-summary

Verifikasi sudah ditambahkan “maximum-path 2”, namun belum ditambahkan “bgp bestpath as-path multipath-relax”

1

2

3

Terlihat gambar di atas belum terjadi load balancing, hanya 1 link saja yg berfungsi.

Kemudian setelah dikonfigurasikan “bgp bestpath as-path multipath-relax” di router bgp 10

4 sudah load sharing

Dari verifikasi di atas dapat kita lihat load sharing telah berhasil dilakukan dengan sukses :D. Namun permasalahannya adalah ketika kedua link memiliki kapasitas bandwidth yg berbeda, maka apa yang terjadi pada proses load balancing itu.

5 bandwidth beda

Ternyata traffic share countnya masih 1:1, padahal bandwidth kedua link tersebut berbeda. Tentunya hal tersebut bisa menjadi problem, terutama apabila tiap – tiap link memiliki selisih bandwidth yg cukup jauh. Untuk mengatasi hal tersebut tambahkan konfigurasi sebagai berikut.

dmz

7 prbandingan load share baik

Terlihat bahwa load balancingnya sudah dalam perbandingan yang baik. Fa0/1 akan lebih sering dipilih untuk mengirimkan trafik, baru ketika link Fa0/1 penuh, link Fa0/0 akan digunakan untuk membantu pengiriman trafik. Sehingga kedua link tersebut bisa digunakan sesuai kemampuannya.

8

Tujuan lab kali ini yaitu mengenal penggunaan BGP REGEX untu keperluan mencari / memfilter suatu router yang diinginkan.

Caranya dengan menggunakan internet yang memiliki tabel BGP yang sangat banyak.

Petunjuk lab

1. Buku web BGP Looking Glasses

2 . Telnet ke salah satu IP server di BGP Looking Glasses

web

3. Setelah di klik pada salah satu link akan muncul dialog box untuk melakukan telnet

telnet

4. Kita akan dibawa masuk ke server setelah telnet berhasil dilakukan, tampilannya seperti di bawah ini.

masuk server

5. Cek BGP pada server tersebut

sh ip bgp

6. Gunakan regexp untuk menampilkan route yang hanya dari AS 680

regexp 680

7. Gunakan regexp untuk menampikan route yg berasal dari AS 680 serta route lain di belakangnya

regexp 680_

8. Gunakan regexp untuk menampilkan semua route yang berasal dari AS 6461

regexp 6461

9. Gunakan regexp untuk menampilkan route yang berasal dari internal BGP

regexp ^$

10. Gunakan regexp untuk menampilkan route yang melewati AS 4725

regexp _4725_

Pada materi atribut kali ini syarat yang digunakan untuk mengaktifkannya dengan mengkonfigurasi summarization routenya pada BGP.

Masih menggunakan topologi yang sama seperti sebelumnya.

topologi

Petunjuk Lab

1. Buat beberapa IP loopback di R4, kemudian advertise ke BGP

2. Lakukan summarisasi untuk beberapa IP loopback tersebut

Konfigurasi routernya adalah sebagai berikut, silahkan digunakan untuk referensi pada topologi yang anda buat.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
router eigrp 111
auto-summary
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.0 0.0.0.255
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 2.2.2.2 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 12.12.12.0 mask 255.255.255.0
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor INTERNAL next-hop-self
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
neighbor 24.24.24.4 remote-as 44
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 23.23.23.0 mask 255.255.255.0
network 33.33.33.33 mask 255.255.255.255
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 2.2.2.2 peer-group INTERNAL
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.41.44.44 255.255.255.255
!
interface Loopback2
ip address 44.42.44.44 255.255.255.255
!
interface Loopback3
ip address 44.43.44.44 255.255.255.255
!
interface Loopback4
ip address 44.44.44.44 255.255.255.255
!
interface Loopback5
ip address 44.45.44.44 255.255.255.255
!
interface Loopback6
ip address 44.46.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 44
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 44.41.44.44 mask 255.255.255.255
network 44.42.44.44 mask 255.255.255.255
network 44.43.44.44 mask 255.255.255.255
network 44.44.44.44 mask 255.255.255.255
network 44.45.44.44 mask 255.255.255.255
network 44.46.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 111
no auto-summary

 

Cek BGP route di R1, dimana muncul banyak network 44.x.x.x

r1 sblm di summ

Lakukan aggregate di R4

R4(config)#router bgp 44

R4(config-router)#aggregate-address 44.0.0.0 255.0.0.0

cek kembali R1, pastikan muncul route summarisasinya

r1 summarisasi

Pada BGP route yg disummarisasi, route aslinya tidak mau hilang, malah nambah 1 route hasil summarisasi.

atomic

R4(config)#router bgp 44

R4(config-router)#aggregate-address 44.0.0.0 255.0.0.0 summary-only

summ only

Sudah muncul hanya 1 route saja.

Kemudian jika yg ingin di summarisasikan hanya beberapa route saja, tidak semua yang dlm 1 subnet, maka konfigurasikan aggregate suppress map seperti di bawah ini.

suppress map

Pada route R1 pada gambar di bawah ini terlihat, summarisasi hanya yang di suppress map saja.

suppress map r1

Dalam BGP tiap routernya harus terhubung secara full mesh untuk dapat saling berkomunikasi, hal ini dapat merepotkan apabila banyak router yang terhubung.  Kita bisa menghubungkan peers dari router – router tersebut kedalam suatu group, sehingga option update-source loopback, remote-as, route-reflector-client, dll tidak perlu diketik berulang – ulang.

Topologinya seperti di bawah ini.

topologi

 

Petunjuk lab :

1. Melanjutkan topologi dari postingan sebelumnya.

2. Hapus konfigurasi BGP 12 gantikan dengan BGP 111.

3. Konfigurasikan peers groupnya

 

Setelah router di config, hasil show run nya sebagai berikut.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
router eigrp 111
auto-summary
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.0 0.0.0.255
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 2.2.2.2 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 12.12.12.0 mask 255.255.255.0
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor INTERNAL next-hop-self
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
neighbor 24.24.24.4 remote-as 44
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 23.23.23.0 mask 255.255.255.0
network 33.33.33.33 mask 255.255.255.255
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 2.2.2.2 peer-group INTERNAL
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 44
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 44.44.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 111
no auto-summary

 

verifikasi

ping r4

r1

r2

r3

r4

Setelah mempelajari BGP attribute origin pada postingan sebelmunya, kini kita belajar BGP attribute community.

Ada 4 macam attribute community, yaitu

1. no-export

2. no-advertise

3. internet

4. local-as

Buat topologi seperti di bawah ini

topologi

Di bawah ini konfigurasi tiap routernya

R1

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 11.11.11.11 255.255.255.255

!

interface Serial0/0

 ip address 12.12.12.1 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 1.1.1.1 0.0.0.0

 network 12.12.12.1 0.0.0.0

 auto-summary

!

router bgp 111

 no synchronization

 bgp log-neighbor-changes

 network 11.11.11.11 mask 255.255.255.255

 neighbor 2.2.2.2 remote-as 111

 neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 send-community

 neighbor 2.2.2.2 route-map no-export out

 no auto-summary

!

access-list 1 permit 11.11.11.11

!

route-map no-export permit 10

 match ip address 1

 set community no-export


R2

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Loopback1

 ip address 22.22.22.22 255.255.255.255

!

interface FastEthernet0/0

 ip address 24.24.24.2 255.255.255.0

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 12.12.12.2 255.255.255.0

 clock rate 2000000

!

interface Serial0/1

 ip address 23.23.23.2 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 2.2.2.2 0.0.0.0

 network 12.12.12.2 0.0.0.0

 network 23.23.23.2 0.0.0.0

 auto-summary

!

router bgp 111

 no synchronization

 bgp log-neighbor-changes

 network 22.22.22.22 mask 255.255.255.255

 neighbor 1.1.1.1 remote-as 111

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 neighbor 3.3.3.3 remote-as 111

 neighbor 3.3.3.3 update-source Loopback0

 neighbor 3.3.3.3 route-reflector-client

 neighbor 3.3.3.3 next-hop-self

 neighbor 24.24.24.4 remote-as 44

 no auto-summary


R3

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

!

interface Loopback1

 ip address 33.33.33.33 255.255.255.255

!

interface Serial0/0

 ip address 23.23.23.3 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 3.3.3.3 0.0.0.0

 network 23.23.23.3 0.0.0.0

 auto-summary

!

router bgp 111

 no synchronization

 bgp log-neighbor-changes

 network 33.33.33.33 mask 255.255.255.255

 neighbor 2.2.2.2 remote-as 111

 neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 send-community

 neighbor 2.2.2.2 route-map NO-ADVERTISE out

 no auto-summary

!

access-list 1 permit 33.33.33.33

!

route-map NO-ADVERTISE permit 10

 match ip address 1

 set community no-advertise

R4

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

!

interface FastEthernet0/0

 ip address 24.24.24.4 255.255.255.0

 duplex auto

 speed auto

!

router bgp 44

 no synchronization

 bgp log-neighbor-changes

 network 4.4.4.4 mask 255.255.255.255

 neighbor 24.24.24.2 remote-as 111

 no auto-summary

verifikasi no -export

Pastikan network 11.11.11.11/32 sudah tidak ada di R4

r4 no-export

r3 no-export

r2 no-export

verifikasi no-advertise

Cek bgp route di R1 dan R4 pastikan network 33.33.33.33/32 sudah tidak ada

r1 no-advertise

r4 no-advertise

r2 no-advertise

Lanjut ke community berikutnya yaitu LOCAL-AS di R1 (diadvertise hanya di confederation iBGP saja). Artinya konfigurasi iBGP (R1, R2 dan R3) harus dirubah dari route reflector menjadi confederation.

Hapus konfigurasi router bgp di semua router, lalu ganti yang baru seperi berikut ini.

R1

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 11.11.11.11 255.255.255.255

!

interface Serial0/0

 ip address 12.12.12.1 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 1.1.1.1 0.0.0.0

 network 12.12.12.1 0.0.0.0

 auto-summary

!

router bgp 12

 no synchronization

 bgp log-neighbor-changes

 bgp confederation identifier 111

 network 11.11.11.11 mask 255.255.255.255

 network 12.12.12.0 mask 255.255.255.0

 redistribute eigrp 1

 neighbor 12.12.12.2 remote-as 12

 neighbor 12.12.12.2 send-community

 neighbor 12.12.12.2 route-map LOCAL-AS out

 no auto-summary

!

access-list 1 permit 11.11.11.11

access-list 2 permit 11.11.11.11

!

route-map no-export permit 10

 match ip address 1

 set community no-export

!

route-map LOCAL-AS permit 10

 match ip address 2

 set community local-AS

R2

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Loopback1

 ip address 22.22.22.22 255.255.255.255

!

interface FastEthernet0/0

 ip address 24.24.24.2 255.255.255.0

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 12.12.12.2 255.255.255.0

 clock rate 2000000

!

interface Serial0/1

 ip address 23.23.23.2 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 2.2.2.2 0.0.0.0

 network 12.12.12.2 0.0.0.0

 network 23.23.23.2 0.0.0.0

 auto-summary

!

router bgp 12

 no synchronization

 bgp log-neighbor-changes

 bgp confederation identifier 111

 bgp confederation peers 3

 network 12.12.12.0 mask 255.255.255.0

 network 22.22.22.22 mask 255.255.255.255

 network 23.23.23.0 mask 255.255.255.0

 network 24.24.24.0 mask 255.255.255.0

 redistribute eigrp 1

 neighbor 12.12.12.1 remote-as 12

 neighbor 12.12.12.1 next-hop-self

 neighbor 23.23.23.3 remote-as 3

 neighbor 23.23.23.3 next-hop-self

 neighbor 24.24.24.4 remote-as 44

 no auto-summary

R3

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

!

interface Loopback1

 ip address 33.33.33.33 255.255.255.255

!

interface Serial0/0

 ip address 23.23.23.3 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 3.3.3.3 0.0.0.0

 network 23.23.23.3 0.0.0.0

 auto-summary

!

router bgp 3

 no synchronization

 bgp log-neighbor-changes

 bgp confederation identifier 111

 bgp confederation peers 12

 network 23.23.23.0 mask 255.255.255.0

 network 33.33.33.33 mask 255.255.255.255

 redistribute eigrp 1

 neighbor 23.23.23.2 remote-as 12

 no auto-summary

!

access-list 1 permit 33.33.33.33

!

route-map NO-ADVERTISE permit 10

 match ip address 1

 set community no-advertise

Verifikasi

Pastikan di R3 sudah tidak ada network 11.11.11.11/32

r3-local-as

Cek di R2 dengan perintah di bawah ini

r2 local as

Pada setiap routing protokol memiliki nilai metric, misalnya rip berdasarkan pemilihan jalur atau hop count, ospf berdasarkan cost, dan eigrp berdasarkan bandwidth dan delay.

Sedangkan BGP memiliki nilai metric yang beragam, sering disebut dengan BGP attribute. Kali ini kita akan mempelajari BGP dengan attribute origin.

Buat topologi seperti gambar di bawah ini.

topologi

Petunjuk Lab

1. Konfigurasi alamat IP pada masing – masing router, bisa disesuaikan dengan postingan sebelumnya.

2. Konfigurasi iBGP peers dengan IP Physical antara R2 dan R3.

3. Konfigurasi eBGP peers dengan IP Physical antara R1 dan R2.

4. Advertise masing – masing IP loopback ke BGP.

5. Pada R2 buat static route ke salah satu IP loopback R3, selanjutnya lakukan redistribute static ke BGP.

6. Pada R3 buat beberapa IP loopback yang kemudian diadvertise ke RIP dan selanjutnya diredistribute ke BGP.

Untuk lebih jelasnya, bisa mengikuti konfigurasi router di bawah ini.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 12.12.12.2 remote-as 321
no auto-summary

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 321
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
redistribute static
neighbor 12.12.12.1 remote-as 123
neighbor 23.23.23.3 remote-as 321
no auto-summary
!
ip route 30.30.30.30 255.255.255.255 23.23.23.3

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Loopback2
ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
network 33.0.0.0
!
router bgp 321
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 30.30.30.30 mask 255.255.255.255
redistribute rip
neighbor 23.23.23.2 remote-as 321
no auto-summary

Verifikasi

ping

sh ip bgp

i = route yg berasal dari BGP (eBGP/iBGP) yang diadvertise melalui perintah network x.x.x.x mask y.y.y.y
e = route yang berasal dari protocol EGP (Saat ini sudah tidak ada protocol tersebut)
? = route yang berasal dari protocol lain (Static/RIP/OSPF/EIGRP) yang diredistribute kedalam BGP

Router R1 untuk menuju network 2.2.2.2 dan 3.3.3.3 adalah via “200 i” yang artinya Next AS Path nya adalah AS 200 dan nilai origin dari routernya adalah i

Router R1 untuk menuju network 50.50.50.50 dan 60.60.60.60 adalah via “200 ?” yang artinya Next AS Path nya adalah AS 200 dan nilai origin dari routernya adalah ?

bgp attribute

Gambar diatas menunjukkan semua atribut yang digunakan oleh BGP

Secara umum atribut BGP terbagi menjadi dua, yakni :
1. Well Known

  • Semua pabrikan perangkat merk apapun yang menjalankan BGP pasti mengenali dan memiliki atribut tipe ini
  • Well known atribut terbagi menjadi dua, yakni :

a. Mandatory

  • Attribut ini pasti ada setiap kali router menjalankan BGP
  • Terbagi menjadi 3 yakni
  1. AS-Path : menampilkan informasi jalur AS suatu route
  2. Next-hop : menampilkan ip via untuk menuju ke suatu route
  3. Origin : menampilkan informasi dari mana route berasal, apakah dari BGp atau IGP yang diredistribute ke BGP

1b. Discreationary

  • Atribut ini baru ada apabila dikonfigurasikan, bila tidak dikonfigurasikan, maka atribut ini tidak dibawa serta oleh BGP
  • Terbagi menjadi 2 yakni
  1. Local Preference: digunakan untuk menentukan jalur upstream
  2. Automic Aggregate : merupakan suatu route hasil summarization

2. Optional

  • Attribut ini hanya dimiliki oleh beberapa pabrikan tertentu saja, tidak semua perangkat yang menjalankan BGP mengenali dan memiliki fitur ini
  • Optional atribut terbagi menjadi dua, yakni

2a. Transitive

  • Attribut ini apabila tidak dikenali oleh perangkat tertentu, maka atribut ini akan tetap diteruskan ke yang lainnya.
  • Terbagi menjadi dua, yakni :
  1. Aggregator : merupakan router yang melakukan summarization
  2. Community, terbagi menjadi 4 :
  • No-export : attribut ini akan menjadikan suatu route diadvertise hanya ke internal bgp saja
  • No-advertise : atribut ini akan menjadikan suatu route tidak diadvertise kemana-mana, baik internal maupun external
  • Internet : atribut ini akan menjadikan route nya diadvertise kemana saja
  • Local-as : atribut ini hanya ada pada bgp confederation, dimana route nya hanya akan diadvertise kedalam sub-as yang sama saja, tidak diadvertise ke sub AS yang lain.

2b. Non Transitive

  • Atribut ini apabila tidak dikenali oleh perangkat tertentu, maka akan didrop atributnya oleh perangkat tersebut
  • Terbagi menjadi tiga yakni
  1. MED : digunakan untuk menentukan trafik kembali/downstream
  2. Originator : menunjukkan router yang menjadi route reflector
  3. Cluster ID, menunjukkan nilai cluster id yang digunakan pada redundant route reflector

BGP Confederation

Pada internal BGP semua router harus dikonfigurasikan secara full mesh untuk dapat saling berkomunikasi, artinya semua router saling terhubung satu sama lain. Pada postingan sebelumnya telah dibahas tentang router reflector, kali ini kita mempelajari tentang BGP CONFEDERATION.

Dengan BGP Confederation dibuat beberapa sub-AS di dalam AS, sehingga se0lah-olah seperti eBGP.

topologi

Petunjuk lab

1. Setting IP pada masing2 router, boleh bebas atau menyesuaikan dengan contoh yang saya buat.

2. Buat BGP Peers dengan menggunakan IP Physicalnya.

3. Gunakan nilai sub-AS sebagain nilai AS pada konfigurasi router BGP pada router.

4. Nilai AS utamanya digunakan sebagai identifiernya.

5. Nilai sub-AS dan main AS boleh bebas, untuk lebih mudah bisa menyesuaikan dengan contoh topologi di atas.

Konfigurasi routernya adalah sebagai berikut

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 14.14.14.1 255.255.255.0
duplex auto
speed auto
!
router bgp 4001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4002 4003
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 14.14.14.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 4002
neighbor 14.14.14.4 remote-as 4001
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 4002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4001 4003
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 25.25.25.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 4001
neighbor 23.23.23.3 remote-as 4003
neighbor 25.25.25.5 remote-as 4002
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 4003
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4001 4002
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 36.36.36.0 mask 255.255.255.0
neighbor 23.23.23.2 remote-as 4002
neighbor 36.36.36.6 remote-as 6
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 14.14.14.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 4001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4002 4003
network 4.4.4.4 mask 255.255.255.255
network 14.14.14.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 4001
no auto-summary

 

R5

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.5 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 4002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
network 5.5.5.5 mask 255.255.255.255
network 25.25.25.0 mask 255.255.255.0
neighbor 25.25.25.2 remote-as 4002
no auto-summary

 

R6

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.6 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 6
no synchronization
bgp log-neighbor-changes
network 6.6.6.6 mask 255.255.255.255
network 36.36.36.0 mask 255.255.255.0
neighbor 36.36.36.3 remote-as 4
no auto-summary

 

Verifikasi

ping

sh ip bgp

sh ip route

Pastikan R1 – R6 bisa ping ke semua IP loopback router.