Category: IS-IS


MPLS LDP IS-IS

Kali ini kita akan belajar konfigurasi MPLS LDP menggunakan routing IS-IS, ldp autoconfig sebenarnya juga bisa diterapkan di IS-IS namun hanya IOS tertentu saja. Pada lab kali ini kita akan ngelab menggunakan basic LDP saja, jadi harus mengkonfigurasi “mpls ip” satu persatu.

Buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Konfigurasikan IP dan routing IS-IS pada semua router

R1(config)#interface Loopback0
R1(config)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#ip router isis
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#ip router isis
R1(config)#router isis
R1(config-router)#net 49.0001.0010.0100.1001.00
R1(config-router)#is-type level-2-only

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#ip router isis
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#ip router isis
R2(config)#router isis
R2(config-router)#net 49.0001.0020.0200.2002.00
R2(config-router)#is-type level-2-only

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#ip router isis
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#ip router isis
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config-if)#ip router isis
R3(config)#router isis
R3(config-router)#net 49.0001.0030.0300.3003.00
R3(config-router)#is-type level-2-only

R4(config)#interface Loopback0
R4(config)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#ip router isis
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config-if)#ip router isis
R4(config)#router isis
R4(config-router)#net 49.0001.0040.0400.4004.00
R4(config-router)#is-type level-2-only

Untuk lebih jelasnya mengenai IS-IS silahkan dilihat artikel saya pada postingan sebelumnya disini

2. Setting MPLS Label Distribution dengan LDP protocol pada semua interface.

R1(config)#mpls label protocol ldp
R1(config)#int g0/0
R1(c0nfig-if)#mpls ip

R2(config)#mpls label protocol ldp
R2(config)#int g0/0
R2(c0nfig-if)#mpls ip
R2(config-if)#int g1/0
R2(c0nfig-if)#mpls ip

R3(config)#mpls label protocol ldp
R3(config)#int g0/0
R3(c0nfig-if)#mpls ip
R3(config-if)#int g1/0
R3(c0nfig-if)#mpls ip

R4(config)#mpls label protocol ldp
R4(config)#int g0/0
R4(c0nfig-if)#mpls ip

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Verifikasi

Lihat interface mplsnya, pastikan sudah pada kondisi UP.

sh mpls int r1 sh mpls int r2 sh mpls int r3 sh mpls int r4

Cek ldpnya, pastikan neighbornya sudah benar.

sh mpls ldp nei r2

Lihat label yang dibentuk oleh mplsnya.

sh mpls for tabel r3

Lakukan ping ke semua IP loopback router pastikan reply semua.

ping r4

Lihat routing tabelnya untuk memastikan sudah dijalankannya routing IS-IS untuk jaringan MPLS.

sh ip route r1

Pada IS-IS yang mengfungsikan kedua IPv4 dan IPv6 dapat diset mode multi topologi, artinya pada multi topologi database dan perhitungan SPF dan databasenya antara IPv4 dan IPv6 berjalan terpisah Hal ini berguna untuk melakukan pemilihan jalur yang kita inginkan, dan juga apabila akan dilakukan migrasi dari IPv4 ke IPv6.

Tapi kelemahannya resource yg digunakan router tentunya semakin besar, karena menjalankan 2 topologi secara bersamaan. Untuk lebih memahaminya langsung saja kita coba lab kan.

Buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Set IPv4 dan routing IS-IS pada R1, R2 dan R3. Caranya bisa lihat disini.

2. Set IPv6 dan routing IS-IS pada R1, R2 dan R3. Caranya bisa lihat disini.

3. Set IPv4, IPv6 dan routing IS-IS sebagai berikut.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int s1/0
R1(config-if)#no sh
R1(config-if)#ip add 14.14.14.1 255.255.255.0
R1(config-if)#ipv6 add 14::1/120
R1(config-if)#ip router isis
R1(config-if)#ipv6 router isis

R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int s1/0
R3(config-if)#no sh
R3(config-if)#ip add 43.43.43.3 255.255.255.0
R3(config-if)#ipv6 add 43::3/120
R3(config-if)#ip router isis
R3(config-if)#ipv6 router isis

R4#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#int lo0
R4(config-if)#ip add 4.4.4.4 255.255.255.255
R4(config-if)#ipv6 add 4::4/128
R4(config-if)#ip router isis
R4(config-if)#ipv6 router isis
R4(config-if)#ex
R4(config)#ipv6 unicast-routing
R4(config)#router isis
R4(config-router)#is-type level-2-only
R4(config-router)#net 49.0001.0040.0400.4004.00
R4(config-router)#int s1/0
R4(config-if)#no sh
R4(config-if)#ip add 14.14.14.4 255.255.255.0
R4(config-if)#ipv6 add 14::4/120
R4(config-if)#ip router isis
R4(config-if)#ipv6 router isis
R4(config-if)#int s1/1
R4(config-if)#no sh
R4(config-if)#ip add 43.43.43.4 255.255.255.0
R4(config-if)#ipv6 add 43::4/120
R4(config-if)#ip router isis
R4(config-if)#ipv6 router isis

4. Set mode multi topologi pada SEMUA ROTUER dengan konfigurasi sebagai berikut.

R1-R4(config)#router isis
R1-R4(config-router)#metric-style wide  (menghasilkan dan menerima TLV untuk alamat IP)
R1-R4(config-router)#address-family ipv6  (memasukka address family IPv6 ke routing IS-IS)
R1-R4(config-router)#multi-topology   (mengaktifkan mode multi topologi)

5. Lakukan traceroute untuk melihat jalur semula atau defaultnya.

before set metric ipv4 before set metric ipv6

Terlihat defaultnya menggunakan 2 jalur atau load sharing.

6. Set route metric IPv4, agar jalur IPv4 dari R1 ke R3 melewati jalur bawah.

R2(config)#interface Fa0/1
R2(config-if)#isis metric 22  (mengeset nilai metric IPv4 pada interface)

R3(config)#interface Fa0/0
R3(config-if)#isis metric 22

Lakukan tracerouter untuk verifikasi

metric hny ipv4 saja

Karena yg kita set hanya metric untuk IPv4 saja maka IPv6 tidak terpengaruh, hal ini membuktikan bahwa database IPv4 dan IPv6 berjalan terpisah.

7. Lakukan set metric pada IPv6, agar IPv6 juga melakukan pindah jalur ke jalur bawah saja.

R2(config)#interface Fa0/1
R2(config-if)#isis ipv6 metric 22  (mengeset nilai metric IPv6 pada interface)

R3(config)#interface Fa0/0
R3(config-if)#isis ipv6 metric 22

Lakukan traceroute untuk verifikasi

after set metric

tracer r4 to r2

Terlihat semua jalur IPv4 dan IPv6 sudah berpindah lewat jalur bawah. Begitu juga R4 ke R2 sudah memilih dengan metric terkecil yaitu lewat R1 dulu.

8. Verifikasi

Lihat database IS-ISnya untuk melihat nilai metric dan mode multi topologi yang digunakan.

isis database r2

Keunggulan IS-IS dibandingkan dengan OSPF adalah pada IS-IS dapat menjalankan IPv4 dan IPv6 dalam interface yg sama secara bersamaan. Langsung saja kita lab kan untuk membuktikannya, buat topologi seperti di bawah ini.

topologi

Petunjuk Lab.

1. Set IPv 4 dan routing ISIS seperti topologi di atas, caranya sudah pernah pada postingan saya sebelumnya. Cek disini.

2. Tambahkan konfigurasi IPv6.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int lo0
R1(config-if)#ipv6 add 1::1/128   (menambahkan IPv6 pada interface)
R1(config-if)#int fa0/0
R1(config-if)#ipv6 add 12::1/120
R1(config-if)#ipv6 router isis   (menambahkan routing ISIS untuk IPv6)
R1(config-if)#int lo0
R1(config-if)#ipv6 router isis
R1(config-if)#ex
R1(config)#ipv6 unicast-routing    (mengaktifkan fitur IPv6 pada router)

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int lo0
R2(config-if)#ipv6 add 2::2/128
R2(config-if)#ipv6 router isis
R2(config-if)#int fa0/0
R2(config-if)#ipv6 add 12::2/120
R2(config-if)#ipv6 router isis
R2(config-if)#int fa0/1
R2(config-if)#ipv6 add 23::2/120
R2(config-if)#ipv6 router isis
R2(config-if)#ex
R2(config)#ipv6 unicast-routing

R3(config)#int lo0
R3(config-if)#ipv6 add 3::3/128
R3(config-if)#ipv6 router isis
R3(config-if)#int fa0/0
R3(config-if)#ipv6 add 23::3/120
R3(config-if)#ipv6 router isis
R3(config-if)#ex
R3(config)#ipv6 unicast-routing

 

3. Verifikasi

Lakukan ke semua IP loopback router, baik IPv4 maupun IPv6. Pastikan reply.

ping r1

Cek routing tabelnya, baik IPv4 maupun IPv6. Pastikan semua IP routernya sudah masuk.

sh ip route r3

Lakukan traceroute untuk melihat jalur yg dilalui

tracer r1

Terlihat IPv4 dan IPv6 keduanya bisa berjalan secara bersamaan.

tracer r3

Lihat database routing ISISnya untuk lebih memastikan IPv4 dan IPv6 telah berjalan secara bersamaan.

sh database r2

Kondisi defaultnya ISIS Level 2 akan membocorkan routingnya ke Level yang lain, dan pada ISIS Level 1 defaultnya tidak membocorkan routingnya. Pada lab kali ini kita akan mengubah kondisi defaultnya, jadi L2 dibuat tidak membocorkan routingya dan L1 dibuta bisa membocorkan routingnya.

Buat topologi seperi di bawah ini.

topologi

Petunjuk LAB

1. Masih menggunakan konfigurasi pada lab multilevel IS-IS sebelumunya, bisa dilihat disini.

 

2. Tambahkan konfigurasi berikut ini pada R2

R2(config)#router isis
R2(config-router)#net 49.0001.0020.0200.2002.00
R2(config-router)#redistribute isis ip level-1 into level-2 distribute-list 101   (merubah level IS-IS dari L1 ke L2, kemudian dimasukkan pada rule access-list 101)
R2(config-router)#redistribute isis ip level-2 into level-1 distribute-list 100  (merubah level IS-IS dari L2 ke L2, kemudian dimasukkan pada rule access-list 100)
!
R2(config)#access-list 100 permit ip host 3.3.3.3 host 255.255.255.255  (memperbolehkan host 3.3.3.3 untuk dapat berkomunikasi)
R2(config)#access-list 101 deny ip host 1.1.1.1 host 255.255.255.255  (melarang host 1.1.1.1 untuk berkomunikasi)
R2(config)#access-list 101 permit ip any any (memperbolehkan IP selain 1.1.1.1 untuk dapat berkomunikasi)

 

3. Verifikasi

Cek routing tabelnya, telah terjadi perubahan dari sebelumnya.

sh ip route r1

sh ip route r3

Lakukan ping dari R3 ke R1 dan lihat hasilnya.

ping r3 ke r1

 

Apabila dilakukan show run pada R2 akan terlihat sebagai berikut.

sh run r2

Pada lab kali ini kita akan mencoba menggabungkan beberapa level IS-IS menjadi satu jaringan yang dapat saling berkomunikasi. Buat topologi seperti di bawah ini.

topologi

 

Petunjuk lab

1. Konfigurasikan IP dan routing, sesuaikan level dan area seperti gambar di atas

Router R1

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#ip router isis
R1(config-if)#isis circuit-type level-1
!
R1(config-if)#interface FastEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#ip router isis
R1(config-if)#isis circuit-type level-1
!
R1(config-if)#router isis
R1(config-router)#net 49.0001.0010.0100.1001.00
R1(config-router)#is-type level-1

 

Router R2

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#ip router isis
!
R2(config-if)#interface FastEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#isis circuit-type level-1
!
R2(config-if)#interface FastEthernet0/1
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#duplex auto
R2(config-if)#speed auto
R2(config-if)#isis circuit-type level-2-only
!
R2(config-if)#router isis
R2(config-router)#net 49.0001.0020.0200.2002.00

 

Router R3

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#ip router isis
R3(config-if)#isis circuit-type level-2-only
!
R3(config-if)#interface FastEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#ip router isis
R3(config-if)#isis circuit-type level-2-only
!
R3(config-if)#router isis
R3(config-router)#net 49.0002.0030.0300.3003.00
R3(config-router)#is-type level-2-only

 

2. Verifikasi

Lihat neighbor pada masing – masing router, pastikan kondisinya UP semua. Kita juga bisa melihat tipe level IS-IS yg digunakan.

sh isis nei r1

sh isis nei r2

sh isis nei r3

Lakukan ping ke semua IP loopback router, pastikan reply.

ping r1

ping r3

 

Lihat routing tabelnya, pastikan semua IP router lawan sudah masuk.

sh ip route r1

sh ip route r2

sh ip route r3

 

Lakukan tracer untuk melihat jalur yang dilewatinya.

tracer r1

tracer r3

 

Cek database is-isnya dari semua router.

sh isis database r1

sh isis database r2

sh isis database r3

Seperti beberapa tipe routing yang lain, pada IS-IS juga bisa dibuat autentikasi. Langsung saja kita buat LABnya, masih menggunakan topologi sebelumnya.  Kita set autentikasinya pada interface R2 dan R3 yang saling terhubung.

topologi isis

1. Set IP interface dan routingnya seperti lab sebelumnya.

2. Set autentikasinya, pada saya ini saya mencoba pada interface R2 dan R3 yg terhubung langsung.

R3(config)#key chain idn  (mengaktifkan manajemen key pada router) (idn merupakan nama kuncinya)
R3(config-keychain)#key 1  (identifier key nya)
R3(config-keychain-key)#key-string idnmd5  (idn md5 merupakan passwordnya)
R3(config)#int fa0/0
R3(config-if)#isis authentication mode md5 level-2  (mengaktifkan autentikasi md5 pada interface)
R3(config-if)#isis authentication key-chain idn  (idn itu password autentikasinya)
R2(config)#key chain idn
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string idnmd5
R3(config)#int fa0/1
R3(config-if)#isis authentication mode md5 level-2
R3(config-if)#isis authentication key-chain idn

3. Verifikasi

Pastikan semua router bisa saling ping

ping r1

Cek routing tabelnya pastikan semua IPnya sudah masuk.

sh ip route r3

Pastikan semua interface dan protokol isis sudah adjaceny dengan baik.

sh clns r2

Pemilihan jalur pada IS-IS didasarkan pada metric, jadi metric yang paling kecil akan dipilih sebagai jalur utama. Default metric pada IS-IS yaitu 10, apabila setiap melewati routing metric tersebut akan bertambah nilainya sesuai metric yang diset pada router tersebut.

Buat topologi seperti di bawah ini.

topologi

 

Petunjuk LAB

1. Set interface dan routingnya sesuai degan gambar di atas untuk lebih mudahnya. Silahkan liat cara config IP dan routingnya pada postingan saya sebelumnya disini.

2. Lakukan traceroute untuk melihat jalur yang dipilih untuk mengirimkan data.

before set metric r3-r1

before set metric

 

Pada gambar di atas terlihat trafik menggunakan2 jalur atau load sharing, kondisi yang kita inginkan adalah trafik dan R1 ke R3 atau sebaliknya melalui R4 saja. Dengan kata lain R4 merupakan link utama sedangkan R2 link backup.

 

3. Set metric pada router.

Set metric pada jalur backup, set metric lebih besar agar trafik memilih metric yang lebih kecil untuk dijadikan jalur utama.

R1(config)#int fa0/0
R1(config-if)#isis metric 20 level-2
R1(config-if)#

R2(config)#int fa0/1
R2(config-if)#isis metric 20 level-2
R2(config-if)#

R3(config)#int fa0/0
R3(config-if)#isis metric 20 level-2

Lakukan traceroute kembali, terlihat sudah sesuai harapan. Trafik dari R1 ke R3 hanya melalui R4 saja.

after set metric r3-r1 after set metric

 

Hal ini disebabkan jalur bawah memiliki metric yang lebih kecil daripada jalur atas.

 

4. Lihat nilai metricnya dari router yang sudah kita set tadi.

sh clns int r1

sh clns int r2

sh clns int r3

 

Cek routing tabel juga bisa digunakan untuk melihat nilai metricnya.

sh ip route r3

Tujuan lab mengganti default tipe network dari IS-IS. Masih menggunakan topologi yang sama, tinggal merubah tipe network R1 dan R2 menjadi point to point.

topologi isis

 

Petunjuk lab

1. Masih menggunakan konfigurasi lab sebelumnya, lihat disini.

2. Ubah tipe network R1 (int fa0/0) R2 (int fa0/0)

config r1 ptp

config r2 ptp

 

3. Verifikasi

Sebuah LSP Node Pseudo tidak lagi dihasilkan untuk segmen ini dalam database. Holdtime LSP 0 menunjukkan bahwa point to point tidak memerlukan LSP.

r1 sh isis database

ID Circuit 00 berarti bahwa tidak ada DIS pada segmen, dan itu karenanya tipe networknya Point-to-Point.

sh isis nei r1 sh isis nei r2

 

ISIS (Intermediate System to Intermediate System) memiliki 3 buah level yaitu, level 1, level 2 dan level 1/2. Level 2 merupakan area backbone, atau yg di OSPF sering disebut dengan area 0. Level 1/2 digunakan untuk menghubunkan antara Level 2 dan Level 1.

Kali ini kita akan membuat ISIS Level 2, ikuti topologi di bawah ini.

topologi isis

 

Petunjuk LAB

1. Set IP pada semua router sesuai dengan topologi di atas.

config int r1

config int r2

config int r3

 

2. Set routing ISIS nya.

R1(config)#router isis
R1(config-router)#net 49.0001.0010.0100.1001.00   (ini merupakan area pada ISIS, nilainya bergantung pada loopback)
R1(config-router)#is-type level-2-only    (mengaktifkan ISIS L2)
R1(config-router)#int fa0/0
R1(config-if)#ip router isis     (setting router isis pada interface)
R1(config-if)#int lo0
R1(config-if)#ip router isis

R2(config)#router isis
R2(config-router)#net 49.0001.0020.0200.2002.00
R2(config-router)#is-type level-2-only
R2(config-router)#int fa0/0
R2(config-if)#ip router isis
R2(config-if)#int lo0
R2(config-if)#ip router isis
R2(config-if)#int fa0/1
R2(config-if)#ip router isis

R3(config)#router isis
R3(config-router)#net 49.0001.0030.0300.3003.00
R3(config-router)#is-type level-2-only
R3(config-router)#int fa0/0
R3(config-if)#ip router isis
R3(config-if)#int lo0
R3(config-if)#ip router isis

 

Verifikasi

Lakukan ping ke semua loopback router, pastikan reply

ping r1

Lakukan traceroute untuk mengetahui lewat jalur mana saja trafik itu.

tracer r1

Lihat routing tabelnya, pastikan semua IP sudah masuk, terlihat jenis Level 2 yang digunakan oleh ISIS

sh ip route r3

 

Lihat neighbor dari router, untuk melihat interface mana saja yang aktif.

sh isis nei r2

Pada ISIS juga memiliki database seperti pada OSPF.

sh isis database r2