Category: MPLS


Pada umumnya ketika lalu lintas IP yg tidak berlabel MPLS diterima di Provider Edge (PE), Time to Live (TTL) dari paket IP akan disalin ke dalam header MPLS. Seperti pd konsep routing, TTL MPlS ditentukan secara hop-by-hop, defaultnya saat dilakukan traceroute dari pelanggan 1 ke pelanggan lain akan melewati hop dari Provider (P). Untuk membuktikannya bisa dilakukan traceroute dari R4 ke R5 dalam topologi di bawah ini.

topologi

Petunjuk LAB

1. Set IP address dan konfigurasikan topologi menjadi MPLS VPN dengan R4 dan R5 menggunakan OSPF, sudah pernah saya bahas pada postingan saya sebelumnya. Cek disini.

Lakukan traceroute dari R4 ke R5 dan sebaliknya, lihat hopnya dan label MPLS

tracer r4 to r5 before

Pada saat dilakukan traceroute dari R4 ke R5 diatas terlihat 2 label MPLS, dan IP dari router Provider (P) muncul.

tracer r5 to r4 before

Tidak jauh beda bila dilakukan traceroute dari R5 ke R4, terdapat 2 label MPLS dan IP dari router provider (P)

 

2. Konfigurasikan TTL propagation pada pada jaringan MPLS Backbone (PE1, P, PE2), agar TTL dari paket yang berasal dari pelanggan tidak disalin ke dalam label MPLS.

PE1-P-PE2(config)#no mpls ip propagate-ttl forwarded

 

3. Verifikasi

Lakukan traceroute lagi setelah dilakukan konfigurasi TTL

tracer r4 to r5 after

Pada gambar di atas terlihat IP dari router Provider (P) sudah tidak muncul, artinya TTL dari costumer sudah tidak disalin ke header MPLS. Dan Label MPLSnya pun sudah berubah menjadi satu, seolah – olah tidak melewati router Provider (P)

tracer r5 to r4 after

Sama halnya bila dilakukan traceroute dari R5 ke R4, walaupun saat dilakukan traceroute tidak muncul IP dari router P tp antara R4 dan R5 masih bisa berkomunikasi dengan baik.

Iklan

Pada lab kali ini kita akan mempelajari konfigurasi MPLS LDP Session Protection, command ini mempunyai tujuannya untuk mempertahankan binding label mereka antara 1 dg lainnya. Ketika link diantara mereka ada yg down, akan mempercepat waktu reconvergence ketika link mereka kembali UP.

Buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

 

2. Setting MPLS Label Distribution dengan protocol LDP pada semua interface.

R1-R4(config)#mpls label protocol ldp  (mengaktifkan mpls ldp)

 

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

 

4. Setting MPLS LDP autoconfig pada routing ospf, untuk mengaktifkan fungsi konfigurasi mpls otomatis pada interface.

R1-R4(config)#router os 1
R1-R4(config-router)#mpls ldp autoconfig

 

5. Setting LDP Session Protection

R1-R4(config)#mpls ldp session protection  (mengaktifkan fitur ldp session protection)

 

6. Verifikasi

Cek apakah LDP session protection sudah aktif

r1

r2

r3

r4

Fungsi protection terjadi ketika ada link down pada interface MPLS, coba matikan salah satu interface R3 yg menuju R2. Bisa dilihat saat link down LDP siap melakukan protecting “Ready –> Protecting”. Ketika interface dihidupkan lagi session secara otomatis melakukan recovery.

r3 to r2 down

Cek bindingnya neighbornya ketika interface down.

ldp binding r3 to r2 down

Packet loss dapat terjadi ketika IGP dan LDP tidak melakukan sinkronisasi dengan benar. Hal ini bisa terjadi ketika ada adjacency IGP baru, router akan mengirim adjacency baru sebelum label LDP terbentuk di tiap – tiap link. Dengan mengkonfigurasikan ldp igp synchronization packet loss yg terjadi pada MPLS dapat berkurang.

Tidak usah berlama – lama langsung saja kita lab kan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Set IP address dan konfigurasikan topologi menjadi MPLS VPN dengan R4 dan R5 menggunakan OSPF, sudah pernah saya bahas pada postingan saya sebelumnya. Cek disini.

2. Aktifkan fungsi LDP IGP Synchronization pada router PE1, P dan PE2, dengan command sebagai berikut.

P(config-if)#int s0/0
P(config-if)#ip ospf cost 100
P(config-if)#int s0/1
P(config-if)#ip ospf cost 100
P(config-if)#router os 1
P(config-router)#mpls ldp autoconfig area 0
P(config-router)#mpls ldp sync
PE2(config)#int fa0/0
PE2(config-if)#ip ospf cost 100
PE2(config-if)#int s0/0
PE2(config-if)#ip ospf cost 100
PE2(config-if)#router os 1
PE2(config-router)#mpls ldp autoconfig area 0
PE2(config-router)#mpls ldp sync

PE1(config)#int fa0/0
PE1(config-if)#ip ospf cost 100
PE1(config-if)#int s0/0
PE1(config-if)#ip ospf cost 100
PE1(config-if)#router os 1
PE1(config-router)#mpls ldp autoconfig area 0
PE1(config-router)#mpls ldp sync

 

3. Verifikasi

Pastikan antara R4 dan R5 sudah bisa berkomunikasi dan menggunakan jalur MPLS, cek dengan melakukan traceroute

tracer r4 to r5 tracer r5 to r4

Cek cost yg telah dikonfigurasikan td, terlihat sudah benar yaitu 100.

p sh ip os int br pe1 sh ip os int br pe2 sh ip os int br

Periksa apakah ldp igp sync nya sudah berjalan dengan baik, terlihat pada router PE1, PE2 dan P sudah reachable.

p igp sync pe1 igp sync pe2 igp sync

Untuk memastikan lagi status ldp igp sync dengan melakukan pemblokiran protokol dengan accesst list, seperti ditunjukkan pada gambar di bawah ini.

set acl make down

Pada gambar di atas saat routing IGPnya down status ldp igp nya menjadi “sync not achieved”

Kita bisa mengamankan peering neighbor LDP dengan menambahkan autentikasi pada peering antar neighbor LDP. Autentikasi yang digunakana adalah MD5, ada beberapa cara dalam menerapkan autentikasi. Agar lebih memahaminya langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk Lab.

1. Setting konfigurasi IP dan routingnya menggunakan OSPF.

2. Setting protocol LDPnya menggunakan LDP OSPF autoconfig, seperti pada postingan saya sebelumnya. Silahkan cek disini.

3. Lalu tambahkan konfigurasi berikut untuk autentikasinya.

R1(config)#mpls ldp neighbor 2.2.2.2 password cisco   (Menentukan otentikasi antara dua neighbor LDP)

R2)config)#mpls ldp password required   (Menentukan bahwa LDP harus menggunakan password ketika akan membangun sesi antara LDP peeringnya)
R2(config)#mpls ldp password option 1 for r2-r3 idnr2r3  (Untuk mengkonfigurasi autentikasi LDP MD5, dengan neighbor yg sudah didaftarkan dlm access list saja)
R2(config)#mpls ldp neighbor 1.1.1.1 password cisco
R2(config)#ip access-list standard r2-r3
R2(config-std-nacl)#permit 2.2.2.2
R2(config-std-nacl)#permit 3.3.3.3

R3(config)#mpls ldp password required
R3(config)#mpls ldp password option 1 for r2-r3 idnr2r3
R3(config)#mpls ldp neighbor 4.4.4.4 password idnr4
R3(config)#mpls label protocol ldp
R3(config)#ip access-list standard r2-r3
R2(config-std-nacl)#permit 2.2.2.2
R2(config-std-nacl)#permit 3.3.3.3

R4(config)#mpls ldp password required
mpls ldp password fallback idnr4    (mengkonfigurasi password MD5 untuk sesi LDP dengan peeringnya)

 

4. Verifikasi

Cek autentikasi yg digunakan pada R1, terlihat MD5 sudah aktif tp tidak meminta password, karena pada R1 tidak di konfigurasikan “password required”. Menggunakan autentikasi neigbor seperti yg dikonfigurasikan di atas.

r1 nei r2

Cek autentikasi pada R2, sesuai dengan konfigurasi autentikasi R2 di atas sehingga untuk peering dengan router R2 membutuhkan password (Password : required).

Untuk terhubung ke R1 menggunakan autentikasi neighbor dan ke R3 menggunakan autentikasi option.

r2 r1 dan r2 r3

Cek autentikasi pada R3, untuk berkomunikasi ke R4 menggunakan mode neighbor dan ke R2 menggunakan mode option.
r3 r2 option 1

Cek konfigurasi pada R4, untuk peering neighbor ke R3 menggunakan mode fallback.

r4 fallback

Kali ini kita akan belajar konfigurasi MPLS LDP menggunakan routing IS-IS, ldp autoconfig sebenarnya juga bisa diterapkan di IS-IS namun hanya IOS tertentu saja. Pada lab kali ini kita akan ngelab menggunakan basic LDP saja, jadi harus mengkonfigurasi “mpls ip” satu persatu.

Buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Konfigurasikan IP dan routing IS-IS pada semua router

R1(config)#interface Loopback0
R1(config)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#ip router isis
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#ip router isis
R1(config)#router isis
R1(config-router)#net 49.0001.0010.0100.1001.00
R1(config-router)#is-type level-2-only

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#ip router isis
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#ip router isis
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#ip router isis
R2(config)#router isis
R2(config-router)#net 49.0001.0020.0200.2002.00
R2(config-router)#is-type level-2-only

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#ip router isis
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#ip router isis
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config-if)#ip router isis
R3(config)#router isis
R3(config-router)#net 49.0001.0030.0300.3003.00
R3(config-router)#is-type level-2-only

R4(config)#interface Loopback0
R4(config)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#ip router isis
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config-if)#ip router isis
R4(config)#router isis
R4(config-router)#net 49.0001.0040.0400.4004.00
R4(config-router)#is-type level-2-only

Untuk lebih jelasnya mengenai IS-IS silahkan dilihat artikel saya pada postingan sebelumnya disini

2. Setting MPLS Label Distribution dengan LDP protocol pada semua interface.

R1(config)#mpls label protocol ldp
R1(config)#int g0/0
R1(c0nfig-if)#mpls ip

R2(config)#mpls label protocol ldp
R2(config)#int g0/0
R2(c0nfig-if)#mpls ip
R2(config-if)#int g1/0
R2(c0nfig-if)#mpls ip

R3(config)#mpls label protocol ldp
R3(config)#int g0/0
R3(c0nfig-if)#mpls ip
R3(config-if)#int g1/0
R3(c0nfig-if)#mpls ip

R4(config)#mpls label protocol ldp
R4(config)#int g0/0
R4(c0nfig-if)#mpls ip

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Verifikasi

Lihat interface mplsnya, pastikan sudah pada kondisi UP.

sh mpls int r1 sh mpls int r2 sh mpls int r3 sh mpls int r4

Cek ldpnya, pastikan neighbornya sudah benar.

sh mpls ldp nei r2

Lihat label yang dibentuk oleh mplsnya.

sh mpls for tabel r3

Lakukan ping ke semua IP loopback router pastikan reply semua.

ping r4

Lihat routing tabelnya untuk memastikan sudah dijalankannya routing IS-IS untuk jaringan MPLS.

sh ip route r1

Pada artikel kali ini kita akan mencoba untuk konfigurasi mpls pada interface secara otomatis, menggunakan routing OSPF. Jadi kita tidak perlu menambahkan command “mpls ip” pada tiap2 interface. Hanya perlu 1 command pada routingya, interface yang terhubung langsung ke OSPF akan otomatis terbentuk sebagai interface mpls.

Langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

2. Setting MPLS Label Distribution dengan protocol LDP pada semua interface.

R1-R4(config)#mpls label protocol ldp

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Setting MPLS LDP autoconfig pada routing ospf, untuk mengaktifkan fungsi konfigurasi mpls otomatis pada interface.

R1-R4(config)#router os 1

R1-R4(config-router)#mpls ldp autoconfig

5. Verifikasi

Show run dari konfigurasi di atas.

sh run ldp autoconfig

Cek interface MPLSnya, sudah berbeda dengan postingan sebelumnya. Jika menggunakan autoconfig, ldpnya menjadi IGP config.

sh mpls int detail

Untuk mematikan fungsi mpls pada suatu interface tidak bisa dilakukan dengan command “no mpls ip”, tp menggunakan command “no mpls ldp igp autoconfig”

no ldp igp autoconf

sh run r1 stlh no ldp auto

Setelah dimatikan fungsi mplsnya, ada beberapa cara untuk mengaktifkannya lagi.

aktifkan mpls int

KIta coba gunakan command “mpls ip” pada tiap2 interface lalu cek lagi hasilnya.

sh mpls int detail dobel

Label Distribution Protocol (LDP) adalah suatu prosedur yang digunakan untuk mendistribusikan ikatan label yang telah dibuat dari satu LSR ke LSR lainnya dan juga sebagai pengatur jalan yang dinamis dalam satu jaringan MPLS. Dalam arsitektur jaringan MPLS, sebuah LSR yang merupakan tujuan atau hop selanjutnya akan mengirimkan informasi tentang ikatan sebuah label ke LSR yang sebelumnya mengirimkan pesan untuk mengikat label tersebut bagi rute paketnya.

Langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

2. Setting MPLS Label Distribution dengan LDP protocol pada semua interface.

R1(config)#mpls label protocol ldp  (mengaktifkan ldp protocol pada router)
R1(config)#int g0/0
R1(c0nfig-if)#mpls ip  (mengaktifkan fungsi mpls pada interface)

R2(config)#mpls label protocol ldp
R2(config)#int g0/0
R2(c0nfig-if)#mpls ip
R2(config-if)#int g1/0
R2(c0nfig-if)#mpls ip

R3(config)#mpls label protocol ldp
R3(config)#int g0/0
R3(c0nfig-if)#mpls ip
R3(config-if)#int g1/0
R3(c0nfig-if)#mpls ip

R4(config)#mpls label protocol ldp
R4(config)#int g0/0
R4(c0nfig-if)#mpls ip

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0  (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Lakukan verifikasi

Lihat interface yg diset mpls td, pastikan beroperasi dengan baik

mpls int r1 mpls int r2 mpls int r3 mpls int r4

Semua router harusnya membentuk adjacency dengan neighbor yang terhubung langsung, tetapi adjacency bisa terbentuk bila ada routing IGPnya untuk mendistribusikan LDP session. Yang akan dipilih sebagai neighbor ada loopback address yg tadi kita buat sebagai  LDP router-id.

mpls ldp nei r1 mpls ldp nei r2 mpls ldp nei r3 mpls ldp nei r4

Lihat label yang telah dibentuk pada MPLS

mpls for tabel r1 mpls for tabel r2 mpls for tabel r3 mpls for tabel r4

Lakukan traceroute untuk memastikan jalur yang digunakan sudah menggunakan MPLS

tracer r1 ke r4 tracer r4 ke r1

Kemudian ping ke semua IP loopback pastikan reply semua.

ping r4

Sesuai dengan namanya any transport over mpls, bisa diterapkan berbagai macam protokol pada jaringan MPLS. Salah satunya enkapsulasi PPP yang akan kita pelajar di bawah ini. Masih menggunakan topologi yang sama.

topologi

 

Petunjuk Lab

1. Set interface semua router seperti topologi di atas.

2. Set routing ospf di R1 dan R2.

3. Set encapsulation PPP pada R1, R2, R3 dan R4.

Router R1

interface Serial0/0
encapsulation ppp    (untuk mengaktifkkan enkapsulasi ppp pada interface)
xconnect 2.2.2.2 30 encapsulation mpls

(30 adalah nilai VC, nilai VC harus sama antara sumber dan tujuan)

(2.2.2.2 merupakan router id)

Router R2

interface Serial0/0
encapsulation ppp
xconnect 1.1.1.1 30 encapsulation mpls

Router R3

interface Serial0/0
ip address 34.34.34.3 255.255.255.0
encapsulation ppp

Router R4

interface Serial0/0
ip address 34.34.34.4 255.255.255.0
encapsulation ppp

 

Verifikasi

Lakukan ping ke IP R3 dan R4

ping r3

ping r4

 

Lihat virtual circuit pada R1 dan R2, pastikan menggunak enkapsulasi PPP

vc r1

vc r2

 

Hasil show run dari lab di atas bisa lihat di bawah ini

Router R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
encapsulation ppp
clock rate 2000000
xconnect 2.2.2.2 30 encapsulation mpls
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0

 

Router R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
encapsulation ppp
clock rate 2000000
xconnect 1.1.1.1 30 encapsulation mpls
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0

AToM (Any Transport Over MPLS)

Masih sama dengan topologi sebelumnya, kita menfungsikan frame relay di jaringan MPLS, bedanya kali ini virtual circuitnya atau yang terhubung ke customer adalah interface ethernet.

topologi

Petunjuk lab

1. Konfigurasikan IP pada semua router, bisa disesuaikan dengan gambar topologi di atas.

Router R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0

Router R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0

Router R5

interface FastEthernet0/0
ip address 56.56.56.5 255.255.255.0

Router R6

interface FastEthernet0/0
ip address 56.56.56.6 255.255.255.0

2. Konfigurasikan routing pada R1 dan R2, kalo saya pakainya ospf.

Router R1

router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0

Router R2

router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0

3. Aktifkan fungsi frame relay pada R1 dan R2.

Router R1

interface FastEthernet0/1
xconnect 2.2.2.2 10 encapsulation mpls

(angka “10” diatas merupakan nilai virtual circuit, jd harus sama dg lawan)

Router R2

interface FastEthernet0/1
xconnect 1.1.1.1 10 encapsulation mpls

Verifikasi

Pastikan virtual circuit sudah pada kondisi UP

r1

r2

Lakukan ping ke loopback R5 dan R6, dan pastikan reply.

r5

r6

Hasil show run lab kali ini adalah sebagai berikut.

Router R1

sh run r1

Router R2

sh run r2

Setelah berhasila membuat jaringan MPLS dengan berbagai macam variasi di postingan sebelumnya, pada kesempatan kali ini kita belajar membuat frame relay di jaringan MPLS. Buat topologi seperti di bawah ini. topologi Petunjuk lab

1. Set IP pada router, boleh bebas boleh mengikuti seperti gambar di atas.

2. Konfigurasikan routing pada R1 dan R2, boleh bebas mau pake routing apa. Klo disini saya pakai ospf.

3. R1 dan R2 difungsikan sebagai Frame Relay.

Router PE1

mpls ldp router-id Loopback0 force   (menetapkan ip dari loopback 0 sebagi router id LDP) dan harus ada

frame-relay switching   (menfungsikan router sebagai frame relay)

interface Serial0/0

encapsulation frame-relay  (mengaktifkan enkapsulasi frame relay di interface)

frame-relay intf-type dce    (memilih tipe enkapsulasi frame relay)

connect FRBCA Serial0/0 102 l2transport  (102 merupakan nilai DLC yang akan diberikan ke R7)

(membuat PVC tidak difungsikan sebagai PVC local, melainkan melalui jalur tunnel backbone)

 

xconnect 2.2.2.2 10 encapsulation mpls (menentukan tujuan router id LPD lawan)

Router PE2

mpls ldp router-id Loopback0 force

frame-relay switching

interface Serial0/0

encapsulation frame-relay

frame-relay intf-type dce

connect FRBCA Serial0/0 201 l2transport

xconnect 1.1.1.1 10 encapsulation mpls

4. Konfigurasikan R7 dan R8 yang merupaka customer yg ingin saling berkomunikasi.

Router R7

interface Serial0/0

encapsulation frame-relay

interface Serial0/0.1 point-to-point

ip address 34.34.34.3 255.255.255.0

frame-relay interface-dlci 102

Router R8

interface Serial0/0

encapsulation frame-relay

interface Serial0/0.1 point-to-point

ip address 34.34.34.4 255.255.255.0

frame-relay interface-dlci 201

Verifikasi

Cek virtual circuitnya apakah sudah UP atau belum

r1

r2

Lakukan ping ke IP loopback R7 dan R8

r7

r8 Hasil dari show run lab di atas adalah sebagai berikut.

Router PE1

frame-relay switching
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 2.2.2.2 20 encapsulation mpls
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
connect FRBCA Serial0/0 102 l2transport
xconnect 2.2.2.2 10 encapsulation mpls
!
mpls ldp router-id Loopback0 force

Router PE2

frame-relay switching
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
!
connect FRBCA Serial0/0 201 l2transport
xconnect 1.1.1.1 10 encapsulation mpls
!
mpls ldp router-id Loopback0 force

Router R7

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1 point-to-point
ip address 34.34.34.3 255.255.255.0
frame-relay interface-dlci 102

Router R8

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1 point-to-point
ip address 34.34.34.4 255.255.255.0
frame-relay interface-dlci 201