Category: OSPF


Pada umumnya ketika lalu lintas IP yg tidak berlabel MPLS diterima di Provider Edge (PE), Time to Live (TTL) dari paket IP akan disalin ke dalam header MPLS. Seperti pd konsep routing, TTL MPlS ditentukan secara hop-by-hop, defaultnya saat dilakukan traceroute dari pelanggan 1 ke pelanggan lain akan melewati hop dari Provider (P). Untuk membuktikannya bisa dilakukan traceroute dari R4 ke R5 dalam topologi di bawah ini.

topologi

Petunjuk LAB

1. Set IP address dan konfigurasikan topologi menjadi MPLS VPN dengan R4 dan R5 menggunakan OSPF, sudah pernah saya bahas pada postingan saya sebelumnya. Cek disini.

Lakukan traceroute dari R4 ke R5 dan sebaliknya, lihat hopnya dan label MPLS

tracer r4 to r5 before

Pada saat dilakukan traceroute dari R4 ke R5 diatas terlihat 2 label MPLS, dan IP dari router Provider (P) muncul.

tracer r5 to r4 before

Tidak jauh beda bila dilakukan traceroute dari R5 ke R4, terdapat 2 label MPLS dan IP dari router provider (P)

 

2. Konfigurasikan TTL propagation pada pada jaringan MPLS Backbone (PE1, P, PE2), agar TTL dari paket yang berasal dari pelanggan tidak disalin ke dalam label MPLS.

PE1-P-PE2(config)#no mpls ip propagate-ttl forwarded

 

3. Verifikasi

Lakukan traceroute lagi setelah dilakukan konfigurasi TTL

tracer r4 to r5 after

Pada gambar di atas terlihat IP dari router Provider (P) sudah tidak muncul, artinya TTL dari costumer sudah tidak disalin ke header MPLS. Dan Label MPLSnya pun sudah berubah menjadi satu, seolah – olah tidak melewati router Provider (P)

tracer r5 to r4 after

Sama halnya bila dilakukan traceroute dari R5 ke R4, walaupun saat dilakukan traceroute tidak muncul IP dari router P tp antara R4 dan R5 masih bisa berkomunikasi dengan baik.

Pada lab kali ini kita akan mempelajari konfigurasi MPLS LDP Session Protection, command ini mempunyai tujuannya untuk mempertahankan binding label mereka antara 1 dg lainnya. Ketika link diantara mereka ada yg down, akan mempercepat waktu reconvergence ketika link mereka kembali UP.

Buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

 

2. Setting MPLS Label Distribution dengan protocol LDP pada semua interface.

R1-R4(config)#mpls label protocol ldp  (mengaktifkan mpls ldp)

 

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

 

4. Setting MPLS LDP autoconfig pada routing ospf, untuk mengaktifkan fungsi konfigurasi mpls otomatis pada interface.

R1-R4(config)#router os 1
R1-R4(config-router)#mpls ldp autoconfig

 

5. Setting LDP Session Protection

R1-R4(config)#mpls ldp session protection  (mengaktifkan fitur ldp session protection)

 

6. Verifikasi

Cek apakah LDP session protection sudah aktif

r1

r2

r3

r4

Fungsi protection terjadi ketika ada link down pada interface MPLS, coba matikan salah satu interface R3 yg menuju R2. Bisa dilihat saat link down LDP siap melakukan protecting “Ready –> Protecting”. Ketika interface dihidupkan lagi session secara otomatis melakukan recovery.

r3 to r2 down

Cek bindingnya neighbornya ketika interface down.

ldp binding r3 to r2 down

Packet loss dapat terjadi ketika IGP dan LDP tidak melakukan sinkronisasi dengan benar. Hal ini bisa terjadi ketika ada adjacency IGP baru, router akan mengirim adjacency baru sebelum label LDP terbentuk di tiap – tiap link. Dengan mengkonfigurasikan ldp igp synchronization packet loss yg terjadi pada MPLS dapat berkurang.

Tidak usah berlama – lama langsung saja kita lab kan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Set IP address dan konfigurasikan topologi menjadi MPLS VPN dengan R4 dan R5 menggunakan OSPF, sudah pernah saya bahas pada postingan saya sebelumnya. Cek disini.

2. Aktifkan fungsi LDP IGP Synchronization pada router PE1, P dan PE2, dengan command sebagai berikut.

P(config-if)#int s0/0
P(config-if)#ip ospf cost 100
P(config-if)#int s0/1
P(config-if)#ip ospf cost 100
P(config-if)#router os 1
P(config-router)#mpls ldp autoconfig area 0
P(config-router)#mpls ldp sync
PE2(config)#int fa0/0
PE2(config-if)#ip ospf cost 100
PE2(config-if)#int s0/0
PE2(config-if)#ip ospf cost 100
PE2(config-if)#router os 1
PE2(config-router)#mpls ldp autoconfig area 0
PE2(config-router)#mpls ldp sync

PE1(config)#int fa0/0
PE1(config-if)#ip ospf cost 100
PE1(config-if)#int s0/0
PE1(config-if)#ip ospf cost 100
PE1(config-if)#router os 1
PE1(config-router)#mpls ldp autoconfig area 0
PE1(config-router)#mpls ldp sync

 

3. Verifikasi

Pastikan antara R4 dan R5 sudah bisa berkomunikasi dan menggunakan jalur MPLS, cek dengan melakukan traceroute

tracer r4 to r5 tracer r5 to r4

Cek cost yg telah dikonfigurasikan td, terlihat sudah benar yaitu 100.

p sh ip os int br pe1 sh ip os int br pe2 sh ip os int br

Periksa apakah ldp igp sync nya sudah berjalan dengan baik, terlihat pada router PE1, PE2 dan P sudah reachable.

p igp sync pe1 igp sync pe2 igp sync

Untuk memastikan lagi status ldp igp sync dengan melakukan pemblokiran protokol dengan accesst list, seperti ditunjukkan pada gambar di bawah ini.

set acl make down

Pada gambar di atas saat routing IGPnya down status ldp igp nya menjadi “sync not achieved”

Kita bisa mengamankan peering neighbor LDP dengan menambahkan autentikasi pada peering antar neighbor LDP. Autentikasi yang digunakana adalah MD5, ada beberapa cara dalam menerapkan autentikasi. Agar lebih memahaminya langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk Lab.

1. Setting konfigurasi IP dan routingnya menggunakan OSPF.

2. Setting protocol LDPnya menggunakan LDP OSPF autoconfig, seperti pada postingan saya sebelumnya. Silahkan cek disini.

3. Lalu tambahkan konfigurasi berikut untuk autentikasinya.

R1(config)#mpls ldp neighbor 2.2.2.2 password cisco   (Menentukan otentikasi antara dua neighbor LDP)

R2)config)#mpls ldp password required   (Menentukan bahwa LDP harus menggunakan password ketika akan membangun sesi antara LDP peeringnya)
R2(config)#mpls ldp password option 1 for r2-r3 idnr2r3  (Untuk mengkonfigurasi autentikasi LDP MD5, dengan neighbor yg sudah didaftarkan dlm access list saja)
R2(config)#mpls ldp neighbor 1.1.1.1 password cisco
R2(config)#ip access-list standard r2-r3
R2(config-std-nacl)#permit 2.2.2.2
R2(config-std-nacl)#permit 3.3.3.3

R3(config)#mpls ldp password required
R3(config)#mpls ldp password option 1 for r2-r3 idnr2r3
R3(config)#mpls ldp neighbor 4.4.4.4 password idnr4
R3(config)#mpls label protocol ldp
R3(config)#ip access-list standard r2-r3
R2(config-std-nacl)#permit 2.2.2.2
R2(config-std-nacl)#permit 3.3.3.3

R4(config)#mpls ldp password required
mpls ldp password fallback idnr4    (mengkonfigurasi password MD5 untuk sesi LDP dengan peeringnya)

 

4. Verifikasi

Cek autentikasi yg digunakan pada R1, terlihat MD5 sudah aktif tp tidak meminta password, karena pada R1 tidak di konfigurasikan “password required”. Menggunakan autentikasi neigbor seperti yg dikonfigurasikan di atas.

r1 nei r2

Cek autentikasi pada R2, sesuai dengan konfigurasi autentikasi R2 di atas sehingga untuk peering dengan router R2 membutuhkan password (Password : required).

Untuk terhubung ke R1 menggunakan autentikasi neighbor dan ke R3 menggunakan autentikasi option.

r2 r1 dan r2 r3

Cek autentikasi pada R3, untuk berkomunikasi ke R4 menggunakan mode neighbor dan ke R2 menggunakan mode option.
r3 r2 option 1

Cek konfigurasi pada R4, untuk peering neighbor ke R3 menggunakan mode fallback.

r4 fallback

Pada artikel kali ini kita akan mencoba untuk konfigurasi mpls pada interface secara otomatis, menggunakan routing OSPF. Jadi kita tidak perlu menambahkan command “mpls ip” pada tiap2 interface. Hanya perlu 1 command pada routingya, interface yang terhubung langsung ke OSPF akan otomatis terbentuk sebagai interface mpls.

Langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

2. Setting MPLS Label Distribution dengan protocol LDP pada semua interface.

R1-R4(config)#mpls label protocol ldp

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Setting MPLS LDP autoconfig pada routing ospf, untuk mengaktifkan fungsi konfigurasi mpls otomatis pada interface.

R1-R4(config)#router os 1

R1-R4(config-router)#mpls ldp autoconfig

5. Verifikasi

Show run dari konfigurasi di atas.

sh run ldp autoconfig

Cek interface MPLSnya, sudah berbeda dengan postingan sebelumnya. Jika menggunakan autoconfig, ldpnya menjadi IGP config.

sh mpls int detail

Untuk mematikan fungsi mpls pada suatu interface tidak bisa dilakukan dengan command “no mpls ip”, tp menggunakan command “no mpls ldp igp autoconfig”

no ldp igp autoconf

sh run r1 stlh no ldp auto

Setelah dimatikan fungsi mplsnya, ada beberapa cara untuk mengaktifkannya lagi.

aktifkan mpls int

KIta coba gunakan command “mpls ip” pada tiap2 interface lalu cek lagi hasilnya.

sh mpls int detail dobel

Label Distribution Protocol (LDP) adalah suatu prosedur yang digunakan untuk mendistribusikan ikatan label yang telah dibuat dari satu LSR ke LSR lainnya dan juga sebagai pengatur jalan yang dinamis dalam satu jaringan MPLS. Dalam arsitektur jaringan MPLS, sebuah LSR yang merupakan tujuan atau hop selanjutnya akan mengirimkan informasi tentang ikatan sebuah label ke LSR yang sebelumnya mengirimkan pesan untuk mengikat label tersebut bagi rute paketnya.

Langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

2. Setting MPLS Label Distribution dengan LDP protocol pada semua interface.

R1(config)#mpls label protocol ldp  (mengaktifkan ldp protocol pada router)
R1(config)#int g0/0
R1(c0nfig-if)#mpls ip  (mengaktifkan fungsi mpls pada interface)

R2(config)#mpls label protocol ldp
R2(config)#int g0/0
R2(c0nfig-if)#mpls ip
R2(config-if)#int g1/0
R2(c0nfig-if)#mpls ip

R3(config)#mpls label protocol ldp
R3(config)#int g0/0
R3(c0nfig-if)#mpls ip
R3(config-if)#int g1/0
R3(c0nfig-if)#mpls ip

R4(config)#mpls label protocol ldp
R4(config)#int g0/0
R4(c0nfig-if)#mpls ip

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0  (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Lakukan verifikasi

Lihat interface yg diset mpls td, pastikan beroperasi dengan baik

mpls int r1 mpls int r2 mpls int r3 mpls int r4

Semua router harusnya membentuk adjacency dengan neighbor yang terhubung langsung, tetapi adjacency bisa terbentuk bila ada routing IGPnya untuk mendistribusikan LDP session. Yang akan dipilih sebagai neighbor ada loopback address yg tadi kita buat sebagai  LDP router-id.

mpls ldp nei r1 mpls ldp nei r2 mpls ldp nei r3 mpls ldp nei r4

Lihat label yang telah dibentuk pada MPLS

mpls for tabel r1 mpls for tabel r2 mpls for tabel r3 mpls for tabel r4

Lakukan traceroute untuk memastikan jalur yang digunakan sudah menggunakan MPLS

tracer r1 ke r4 tracer r4 ke r1

Kemudian ping ke semua IP loopback pastikan reply semua.

ping r4

Pada OSPFv3 kita bisa menerapkan suatu autentikasi dan enkripsi sehingga hanya router yang mempunyai kunci saja yang bisa terhubung. Ada berbagai macam tipe autentikasi pada ospfv3 seperti md5 dan sha-1

Gunakan topologi sederhana seperti di bawah ini, kita akan menerapkan enkripsi dan autentikasi di R1 dan R2.

topologi

Petunjuk lab

1. Konfigurasi IPv6 dan OSPf v3 masih sama seprti yang sudah – sudah, bisa dilihat disini

2. Konfigurasi enkripsi dan autentikasi di R1, syaratnya kedua ujung yg dikonfigurasi autentikasi dan enkripsi harus memiliki mode, tipe dan nilai yang sama.

Router R1

R1(config)#int fa0/0

R1(config-if)ipv6 ospf encryption ipsec spi 1000 esp des 1234567890ABCDEF md5 1234567890ABCDEF1234567890ABCDEF

(ipsec = merupakan jenis enkripsi)

(spi = security parameter index, 1000 merupakan nilai yg saya set)

(esp = jenis enkapsulasi)

(des = menggunakan jenis enkripsi DES, memiliki kunci sebanyak 16 char hexa. Bila memilih “0” maka kunci berbentuk plain-text atau tidak akan di enkripsi)

(md5 = jenis autentikasi yg key nya ada 32 char hexa)

Router R2

R2(config)#int fa0/0

R2(config-if)ipv6 ospf encryption ipsec spi 1000 esp des 1234567890ABCDEF md5 1234567890ABCDEF1234567890ABCDEF

Kita dapat menyesuaikan mode enkripsi dan autentikasi sesuai yg kita butuhkan, karena ada berbagai modenya dan jumlah key nya pun berbeda – beda. Seperti terlihat di bawah ini.

tipe autentikasi dan enkripsi

tipe2 autentikasi dan enkripsi

 

 

Verifikasi

Lakukan ping untuk memastikan setelah dilakukan autentikasi dan enkripsi link kita tetap hidup

ping r1

ping r2

Cek autentikasi dan enkripsinya pastikan sudah muncul seperti yg kita set.

encryption r2

encryption

Tujuan dari lab kali ini adalah melakukan pemilihan jalur trafik yang akan dilalui pada OSPFv3, dengan cara mengkonfigurasi cost pada interfacenya. Cost yg terkecil yang akan dipilih sebagai jalur utama, karena pemilihan jalur pada OSPF berdasarkan dengan rumus 1o^8 / cost.

Buat topologi seperti di bawah ini.

topologi

Petunjuk lab1.

1. Masih menggunakan topologi sebelumnya, tinggal menambahkan R4.

 

2. Set interface dan ospf v3 pada R4.

ipv6 unicast-routing
!
interface Loopback0
ipv6 address 4::4/128
ipv6 ospf 1 area 0

interface Serial1/0
ipv6 address 14::4/126
ipv6 ospf 1 area 0
!
interface Serial1/1
ipv6 address 43::4/126
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 4.4.4.4

 

3. Lakukann traceroute untuk melihat default trafiknya lewat mana.

before set cost

Pada gambar di atas terlihat bahwa trafik dar R1 menuju R3 memilih lewat jalur R2 dahulu.

 

4. Sekarang konfigurasikan cost pada R3 dan R2, agar trafik dari R1 ke R3 lewatnya R4.

Router R2

R2(config)#interface FastEthernet0/1
R2(config-if)#ipv6 ospf cost 777    (menentukan nilai cost dari suatu interface)

Router R3

R3(config)#interface FastEthernet0/0
R3(config-if)#ipv6 ospf cost 777

 

5. Cek apakah cost pada interface R2 dan R3 sudah berubah apa belom.

r2 cost

r3 cost

 

 

6. Lakukan traceroute lagi dari R1 ke R3, terlihat trafiknya lebih memilih lewat R4 daripada R2.

after set cost tracer r1 ke r3

Mengubah default tipe network dari OSPF, kali ini kita akan belajar mengubah default network broadcast pada ethernet menjadi point-to-point. Masih menggunakan topologi yg sama.

topologi

Petunjuk lab

1. Masih melanjutkan lab sebelumnya, lihat disini.

2. Ubah network type di R1 dan R2 dari broadcast ke point-to-point, dengan menambahkan command di bawah ini.

R1(config)#int fa0/0
R1(config-if)#ipv6 ospf network point-to-point

R2(config)#int fa0/0
R2(config-if)#ipv6 ospf network point-to-point

Ada 4 macam network pada fast ethernet, adalah sebagai berikut.

macam2 net type

Verifikasi

Pastikan network typenya sudah berubah menjadi point to point.

r1

r2

Hasil show run nya adalah sebagai berikut.

Router R1

ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address 1::1/128
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 12::1/126
ipv6 ospf network point-to-point
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes

 

Router R2

ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address 2::2/128
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 12::2/126
ipv6 ospf network point-to-point
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 23::1/126
ipv6 address 23::2/126
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes

OSPF Version 3 adalah routing protocol OSPF yang support digunakan pada IPv6. Mari kita ngelab dg OSPF V3 dan IPv6, topologinya seperti di bawah ini.

topologi

Petunjuk Lab

1. Hidupkan fungsi ipv6

R1-R3(config)#ipv6 unicast-routing

2. Set IPv6 pada interface

set int r1

set int r2

set int r3

3. Set router OSPFv3 pada interface

set ospf r1

set ospf r2

set ospf r3

Hasil show run nya adalah sebagai berikut

Router R1

ipv6 unicast-routing   (untuk mengaktifkan fitur IPv6 pada router, krn secara default tidak aktif)

interface Loopback0
no ip address
ipv6 address 1::1/128  (/128 bila di ipv4 itu /32)
ipv6 ospf 1 area 0          (memasukkan interface loopback ke routing ospf v3 area 0)
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 12::1/126  (/126 bila di ipv4 itu /30)
ipv6 ospf 1 area 0
!
ipv6 router ospf 1   (mengaktifkan router ospfv3)
router-id 1.1.1.1      (router-id ospfv3 router 1, boleh bebas tp wajib diisi)

 

Router R2

ipv6 unicast-routing

interface Loopback0
no ip address
ipv6 address 2::2/128
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 12::2/126
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 23::1/126
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 2.2.2.2

 

Router R3

ipv6 unicast-routing

interface Loopback0
no ip address
ipv6 address 3::3/128
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 23::3/126
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 3.3.3.3

 

Verifikasi

Lihat database ospfnya, terliah router-id sudah muncul

ospf database

Lakukan ping ke semua ip loopback router, pastikan sudah reply.

ping

lihat routing tabelnya, terlihat sudah ada semua IP tujuan. Dan tipenya sudah “O” berarti sudah menggunakan OSPF.

r1

Lakukan traceroute untuk melihat lewat jalur mana saja trafiknya.

tracer