Tag Archive: jaringan komputer


Tujuan lab kali ini yaitu mengenal penggunaan BGP REGEX untu keperluan mencari / memfilter suatu router yang diinginkan.

Caranya dengan menggunakan internet yang memiliki tabel BGP yang sangat banyak.

Petunjuk lab

1. Buku web BGP Looking Glasses

2 . Telnet ke salah satu IP server di BGP Looking Glasses

web

3. Setelah di klik pada salah satu link akan muncul dialog box untuk melakukan telnet

telnet

4. Kita akan dibawa masuk ke server setelah telnet berhasil dilakukan, tampilannya seperti di bawah ini.

masuk server

5. Cek BGP pada server tersebut

sh ip bgp

6. Gunakan regexp untuk menampilkan route yang hanya dari AS 680

regexp 680

7. Gunakan regexp untuk menampikan route yg berasal dari AS 680 serta route lain di belakangnya

regexp 680_

8. Gunakan regexp untuk menampilkan semua route yang berasal dari AS 6461

regexp 6461

9. Gunakan regexp untuk menampilkan route yang berasal dari internal BGP

regexp ^$

10. Gunakan regexp untuk menampilkan route yang melewati AS 4725

regexp _4725_

Pada materi atribut kali ini syarat yang digunakan untuk mengaktifkannya dengan mengkonfigurasi summarization routenya pada BGP.

Masih menggunakan topologi yang sama seperti sebelumnya.

topologi

Petunjuk Lab

1. Buat beberapa IP loopback di R4, kemudian advertise ke BGP

2. Lakukan summarisasi untuk beberapa IP loopback tersebut

Konfigurasi routernya adalah sebagai berikut, silahkan digunakan untuk referensi pada topologi yang anda buat.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
router eigrp 111
auto-summary
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.0 0.0.0.255
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 2.2.2.2 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 12.12.12.0 mask 255.255.255.0
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor INTERNAL next-hop-self
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
neighbor 24.24.24.4 remote-as 44
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 23.23.23.0 mask 255.255.255.0
network 33.33.33.33 mask 255.255.255.255
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 2.2.2.2 peer-group INTERNAL
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.41.44.44 255.255.255.255
!
interface Loopback2
ip address 44.42.44.44 255.255.255.255
!
interface Loopback3
ip address 44.43.44.44 255.255.255.255
!
interface Loopback4
ip address 44.44.44.44 255.255.255.255
!
interface Loopback5
ip address 44.45.44.44 255.255.255.255
!
interface Loopback6
ip address 44.46.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 44
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 44.41.44.44 mask 255.255.255.255
network 44.42.44.44 mask 255.255.255.255
network 44.43.44.44 mask 255.255.255.255
network 44.44.44.44 mask 255.255.255.255
network 44.45.44.44 mask 255.255.255.255
network 44.46.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 111
no auto-summary

 

Cek BGP route di R1, dimana muncul banyak network 44.x.x.x

r1 sblm di summ

Lakukan aggregate di R4

R4(config)#router bgp 44

R4(config-router)#aggregate-address 44.0.0.0 255.0.0.0

cek kembali R1, pastikan muncul route summarisasinya

r1 summarisasi

Pada BGP route yg disummarisasi, route aslinya tidak mau hilang, malah nambah 1 route hasil summarisasi.

atomic

R4(config)#router bgp 44

R4(config-router)#aggregate-address 44.0.0.0 255.0.0.0 summary-only

summ only

Sudah muncul hanya 1 route saja.

Kemudian jika yg ingin di summarisasikan hanya beberapa route saja, tidak semua yang dlm 1 subnet, maka konfigurasikan aggregate suppress map seperti di bawah ini.

suppress map

Pada route R1 pada gambar di bawah ini terlihat, summarisasi hanya yang di suppress map saja.

suppress map r1

Dalam BGP tiap routernya harus terhubung secara full mesh untuk dapat saling berkomunikasi, hal ini dapat merepotkan apabila banyak router yang terhubung.  Kita bisa menghubungkan peers dari router – router tersebut kedalam suatu group, sehingga option update-source loopback, remote-as, route-reflector-client, dll tidak perlu diketik berulang – ulang.

Topologinya seperti di bawah ini.

topologi

 

Petunjuk lab :

1. Melanjutkan topologi dari postingan sebelumnya.

2. Hapus konfigurasi BGP 12 gantikan dengan BGP 111.

3. Konfigurasikan peers groupnya

 

Setelah router di config, hasil show run nya sebagai berikut.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
router eigrp 111
auto-summary
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.0 0.0.0.255
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 2.2.2.2 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 12.12.12.0 mask 255.255.255.0
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 24.24.24.0 mask 255.255.255.0
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor INTERNAL next-hop-self
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
neighbor 24.24.24.4 remote-as 44
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
auto-summary
!
router bgp 111
no synchronization
bgp log-neighbor-changes
network 23.23.23.0 mask 255.255.255.0
network 33.33.33.33 mask 255.255.255.255
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 111
neighbor INTERNAL update-source Loopback0
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 2.2.2.2 peer-group INTERNAL
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
router bgp 44
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 44.44.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 111
no auto-summary

 

verifikasi

ping r4

r1

r2

r3

r4

Setelah mempelajari BGP attribute origin pada postingan sebelmunya, kini kita belajar BGP attribute community.

Ada 4 macam attribute community, yaitu

1. no-export

2. no-advertise

3. internet

4. local-as

Buat topologi seperti di bawah ini

topologi

Di bawah ini konfigurasi tiap routernya

R1

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 11.11.11.11 255.255.255.255

!

interface Serial0/0

 ip address 12.12.12.1 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 1.1.1.1 0.0.0.0

 network 12.12.12.1 0.0.0.0

 auto-summary

!

router bgp 111

 no synchronization

 bgp log-neighbor-changes

 network 11.11.11.11 mask 255.255.255.255

 neighbor 2.2.2.2 remote-as 111

 neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 send-community

 neighbor 2.2.2.2 route-map no-export out

 no auto-summary

!

access-list 1 permit 11.11.11.11

!

route-map no-export permit 10

 match ip address 1

 set community no-export


R2

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Loopback1

 ip address 22.22.22.22 255.255.255.255

!

interface FastEthernet0/0

 ip address 24.24.24.2 255.255.255.0

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 12.12.12.2 255.255.255.0

 clock rate 2000000

!

interface Serial0/1

 ip address 23.23.23.2 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 2.2.2.2 0.0.0.0

 network 12.12.12.2 0.0.0.0

 network 23.23.23.2 0.0.0.0

 auto-summary

!

router bgp 111

 no synchronization

 bgp log-neighbor-changes

 network 22.22.22.22 mask 255.255.255.255

 neighbor 1.1.1.1 remote-as 111

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 neighbor 3.3.3.3 remote-as 111

 neighbor 3.3.3.3 update-source Loopback0

 neighbor 3.3.3.3 route-reflector-client

 neighbor 3.3.3.3 next-hop-self

 neighbor 24.24.24.4 remote-as 44

 no auto-summary


R3

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

!

interface Loopback1

 ip address 33.33.33.33 255.255.255.255

!

interface Serial0/0

 ip address 23.23.23.3 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 3.3.3.3 0.0.0.0

 network 23.23.23.3 0.0.0.0

 auto-summary

!

router bgp 111

 no synchronization

 bgp log-neighbor-changes

 network 33.33.33.33 mask 255.255.255.255

 neighbor 2.2.2.2 remote-as 111

 neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 send-community

 neighbor 2.2.2.2 route-map NO-ADVERTISE out

 no auto-summary

!

access-list 1 permit 33.33.33.33

!

route-map NO-ADVERTISE permit 10

 match ip address 1

 set community no-advertise

R4

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

!

interface FastEthernet0/0

 ip address 24.24.24.4 255.255.255.0

 duplex auto

 speed auto

!

router bgp 44

 no synchronization

 bgp log-neighbor-changes

 network 4.4.4.4 mask 255.255.255.255

 neighbor 24.24.24.2 remote-as 111

 no auto-summary

verifikasi no -export

Pastikan network 11.11.11.11/32 sudah tidak ada di R4

r4 no-export

r3 no-export

r2 no-export

verifikasi no-advertise

Cek bgp route di R1 dan R4 pastikan network 33.33.33.33/32 sudah tidak ada

r1 no-advertise

r4 no-advertise

r2 no-advertise

Lanjut ke community berikutnya yaitu LOCAL-AS di R1 (diadvertise hanya di confederation iBGP saja). Artinya konfigurasi iBGP (R1, R2 dan R3) harus dirubah dari route reflector menjadi confederation.

Hapus konfigurasi router bgp di semua router, lalu ganti yang baru seperi berikut ini.

R1

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 11.11.11.11 255.255.255.255

!

interface Serial0/0

 ip address 12.12.12.1 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 1.1.1.1 0.0.0.0

 network 12.12.12.1 0.0.0.0

 auto-summary

!

router bgp 12

 no synchronization

 bgp log-neighbor-changes

 bgp confederation identifier 111

 network 11.11.11.11 mask 255.255.255.255

 network 12.12.12.0 mask 255.255.255.0

 redistribute eigrp 1

 neighbor 12.12.12.2 remote-as 12

 neighbor 12.12.12.2 send-community

 neighbor 12.12.12.2 route-map LOCAL-AS out

 no auto-summary

!

access-list 1 permit 11.11.11.11

access-list 2 permit 11.11.11.11

!

route-map no-export permit 10

 match ip address 1

 set community no-export

!

route-map LOCAL-AS permit 10

 match ip address 2

 set community local-AS

R2

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Loopback1

 ip address 22.22.22.22 255.255.255.255

!

interface FastEthernet0/0

 ip address 24.24.24.2 255.255.255.0

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 12.12.12.2 255.255.255.0

 clock rate 2000000

!

interface Serial0/1

 ip address 23.23.23.2 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 2.2.2.2 0.0.0.0

 network 12.12.12.2 0.0.0.0

 network 23.23.23.2 0.0.0.0

 auto-summary

!

router bgp 12

 no synchronization

 bgp log-neighbor-changes

 bgp confederation identifier 111

 bgp confederation peers 3

 network 12.12.12.0 mask 255.255.255.0

 network 22.22.22.22 mask 255.255.255.255

 network 23.23.23.0 mask 255.255.255.0

 network 24.24.24.0 mask 255.255.255.0

 redistribute eigrp 1

 neighbor 12.12.12.1 remote-as 12

 neighbor 12.12.12.1 next-hop-self

 neighbor 23.23.23.3 remote-as 3

 neighbor 23.23.23.3 next-hop-self

 neighbor 24.24.24.4 remote-as 44

 no auto-summary

R3

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

!

interface Loopback1

 ip address 33.33.33.33 255.255.255.255

!

interface Serial0/0

 ip address 23.23.23.3 255.255.255.0

 clock rate 2000000

!

router eigrp 1

 network 3.3.3.3 0.0.0.0

 network 23.23.23.3 0.0.0.0

 auto-summary

!

router bgp 3

 no synchronization

 bgp log-neighbor-changes

 bgp confederation identifier 111

 bgp confederation peers 12

 network 23.23.23.0 mask 255.255.255.0

 network 33.33.33.33 mask 255.255.255.255

 redistribute eigrp 1

 neighbor 23.23.23.2 remote-as 12

 no auto-summary

!

access-list 1 permit 33.33.33.33

!

route-map NO-ADVERTISE permit 10

 match ip address 1

 set community no-advertise

Verifikasi

Pastikan di R3 sudah tidak ada network 11.11.11.11/32

r3-local-as

Cek di R2 dengan perintah di bawah ini

r2 local as

Pada setiap routing protokol memiliki nilai metric, misalnya rip berdasarkan pemilihan jalur atau hop count, ospf berdasarkan cost, dan eigrp berdasarkan bandwidth dan delay.

Sedangkan BGP memiliki nilai metric yang beragam, sering disebut dengan BGP attribute. Kali ini kita akan mempelajari BGP dengan attribute origin.

Buat topologi seperti gambar di bawah ini.

topologi

Petunjuk Lab

1. Konfigurasi alamat IP pada masing – masing router, bisa disesuaikan dengan postingan sebelumnya.

2. Konfigurasi iBGP peers dengan IP Physical antara R2 dan R3.

3. Konfigurasi eBGP peers dengan IP Physical antara R1 dan R2.

4. Advertise masing – masing IP loopback ke BGP.

5. Pada R2 buat static route ke salah satu IP loopback R3, selanjutnya lakukan redistribute static ke BGP.

6. Pada R3 buat beberapa IP loopback yang kemudian diadvertise ke RIP dan selanjutnya diredistribute ke BGP.

Untuk lebih jelasnya, bisa mengikuti konfigurasi router di bawah ini.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 12.12.12.2 remote-as 321
no auto-summary

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 321
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
redistribute static
neighbor 12.12.12.1 remote-as 123
neighbor 23.23.23.3 remote-as 321
no auto-summary
!
ip route 30.30.30.30 255.255.255.255 23.23.23.3

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Loopback2
ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
network 33.0.0.0
!
router bgp 321
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 30.30.30.30 mask 255.255.255.255
redistribute rip
neighbor 23.23.23.2 remote-as 321
no auto-summary

Verifikasi

ping

sh ip bgp

i = route yg berasal dari BGP (eBGP/iBGP) yang diadvertise melalui perintah network x.x.x.x mask y.y.y.y
e = route yang berasal dari protocol EGP (Saat ini sudah tidak ada protocol tersebut)
? = route yang berasal dari protocol lain (Static/RIP/OSPF/EIGRP) yang diredistribute kedalam BGP

Router R1 untuk menuju network 2.2.2.2 dan 3.3.3.3 adalah via “200 i” yang artinya Next AS Path nya adalah AS 200 dan nilai origin dari routernya adalah i

Router R1 untuk menuju network 50.50.50.50 dan 60.60.60.60 adalah via “200 ?” yang artinya Next AS Path nya adalah AS 200 dan nilai origin dari routernya adalah ?

bgp attribute

Gambar diatas menunjukkan semua atribut yang digunakan oleh BGP

Secara umum atribut BGP terbagi menjadi dua, yakni :
1. Well Known

  • Semua pabrikan perangkat merk apapun yang menjalankan BGP pasti mengenali dan memiliki atribut tipe ini
  • Well known atribut terbagi menjadi dua, yakni :

a. Mandatory

  • Attribut ini pasti ada setiap kali router menjalankan BGP
  • Terbagi menjadi 3 yakni
  1. AS-Path : menampilkan informasi jalur AS suatu route
  2. Next-hop : menampilkan ip via untuk menuju ke suatu route
  3. Origin : menampilkan informasi dari mana route berasal, apakah dari BGp atau IGP yang diredistribute ke BGP

1b. Discreationary

  • Atribut ini baru ada apabila dikonfigurasikan, bila tidak dikonfigurasikan, maka atribut ini tidak dibawa serta oleh BGP
  • Terbagi menjadi 2 yakni
  1. Local Preference: digunakan untuk menentukan jalur upstream
  2. Automic Aggregate : merupakan suatu route hasil summarization

2. Optional

  • Attribut ini hanya dimiliki oleh beberapa pabrikan tertentu saja, tidak semua perangkat yang menjalankan BGP mengenali dan memiliki fitur ini
  • Optional atribut terbagi menjadi dua, yakni

2a. Transitive

  • Attribut ini apabila tidak dikenali oleh perangkat tertentu, maka atribut ini akan tetap diteruskan ke yang lainnya.
  • Terbagi menjadi dua, yakni :
  1. Aggregator : merupakan router yang melakukan summarization
  2. Community, terbagi menjadi 4 :
  • No-export : attribut ini akan menjadikan suatu route diadvertise hanya ke internal bgp saja
  • No-advertise : atribut ini akan menjadikan suatu route tidak diadvertise kemana-mana, baik internal maupun external
  • Internet : atribut ini akan menjadikan route nya diadvertise kemana saja
  • Local-as : atribut ini hanya ada pada bgp confederation, dimana route nya hanya akan diadvertise kedalam sub-as yang sama saja, tidak diadvertise ke sub AS yang lain.

2b. Non Transitive

  • Atribut ini apabila tidak dikenali oleh perangkat tertentu, maka akan didrop atributnya oleh perangkat tersebut
  • Terbagi menjadi tiga yakni
  1. MED : digunakan untuk menentukan trafik kembali/downstream
  2. Originator : menunjukkan router yang menjadi route reflector
  3. Cluster ID, menunjukkan nilai cluster id yang digunakan pada redundant route reflector

BGP Confederation

Pada internal BGP semua router harus dikonfigurasikan secara full mesh untuk dapat saling berkomunikasi, artinya semua router saling terhubung satu sama lain. Pada postingan sebelumnya telah dibahas tentang router reflector, kali ini kita mempelajari tentang BGP CONFEDERATION.

Dengan BGP Confederation dibuat beberapa sub-AS di dalam AS, sehingga se0lah-olah seperti eBGP.

topologi

Petunjuk lab

1. Setting IP pada masing2 router, boleh bebas atau menyesuaikan dengan contoh yang saya buat.

2. Buat BGP Peers dengan menggunakan IP Physicalnya.

3. Gunakan nilai sub-AS sebagain nilai AS pada konfigurasi router BGP pada router.

4. Nilai AS utamanya digunakan sebagai identifiernya.

5. Nilai sub-AS dan main AS boleh bebas, untuk lebih mudah bisa menyesuaikan dengan contoh topologi di atas.

Konfigurasi routernya adalah sebagai berikut

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 14.14.14.1 255.255.255.0
duplex auto
speed auto
!
router bgp 4001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4002 4003
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 14.14.14.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 4002
neighbor 14.14.14.4 remote-as 4001
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 4002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4001 4003
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 25.25.25.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 4001
neighbor 23.23.23.3 remote-as 4003
neighbor 25.25.25.5 remote-as 4002
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 4003
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4001 4002
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 36.36.36.0 mask 255.255.255.0
neighbor 23.23.23.2 remote-as 4002
neighbor 36.36.36.6 remote-as 6
no auto-summary

 

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 14.14.14.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 4001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
bgp confederation peers 4002 4003
network 4.4.4.4 mask 255.255.255.255
network 14.14.14.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 4001
no auto-summary

 

R5

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.5 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 4002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 4
network 5.5.5.5 mask 255.255.255.255
network 25.25.25.0 mask 255.255.255.0
neighbor 25.25.25.2 remote-as 4002
no auto-summary

 

R6

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.6 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 6
no synchronization
bgp log-neighbor-changes
network 6.6.6.6 mask 255.255.255.255
network 36.36.36.0 mask 255.255.255.0
neighbor 36.36.36.3 remote-as 4
no auto-summary

 

Verifikasi

ping

sh ip bgp

sh ip route

Pastikan R1 – R6 bisa ping ke semua IP loopback router.

 

BGP Authentication

Pembahasan selanjutnya yaitu tentang autentikasi pada routing BGP, pada BGP hanya ada authentikasi MD5, tidak ada clear text. Autentikasi dipasang pada neighbor routingnya.

Masih melanjutkan topologi sebelumnya, konfigurasi autentikasi pada R2 dan R3.

topologi

Pastikan BGP adjacency masih terbentuk dengan mengetik show ip bgp summary.

Konfigurasi routernya sebagai berikut.

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 12
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.32.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 12
neighbor 12.12.12.1 next-hop-self
neighbor 23.23.23.3 remote-as 3
neighbor 23.23.23.3 password rahasia
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
neighbor 23.23.23.2 remote-as 12
neighbor 23.23.23.2 password rahasia
no auto-summary

 

Verifikasi

r2

r3

Pada latihan BGP kali ini kita akan belajar NEXT – HOP -SELF dan fungsinya dikonfigurasikan pada routing BGP. Serta mengetahui bahwa route yang diadvertis ke BGP tidak semuanya akan tampil dalam routing tabel, hal ini disebabkan IP next – hop nya unreachable.

topologi

Petunjuk lab

1. Setting IP pada semua router

2. Konfigurasi iBGP peers antara R1 dan R2

3. Konfigurasi eBGP peers antara R2 dan R3

4. Advertise masing – masing IP loopback ke BGP

5. Apabila tidak di set next – hop – self, R1 dan R3 tidak bisa melakukan ping

 

Konfigurasikan router seperi di bawah ini

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 12.12.12.2 remote-as 12
no auto-summary

 

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 12.12.12.1 remote-as 12
neighbor 12.12.12.1 next-hop-self
neighbor 23.23.23.3 remote-as 3
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 23.23.23.2 remote-as 12
no auto-summary

 

Verifikasi

1

Pada kasus di atas R2 di setting next – hop – self untuk menyambungkan koneksi dari R1 ke R3. Sebelum di setting next – hop -self pada R2, R1 dan R3 tidak dapat berkomunikasi (unreachable) karena tidak link yg menyambungkan diantara R1 dan R3.

Pada artikel kali ini kita akan belajar cara mengkonfigurasikan Peers BGP Eksternal antara R2 (AS-12) dan R3 (AS-3) menggunakan interface loopback masing – masing router.

Masih menggunakan topologi sebelumnya, seperti di bawah ini. Simulasi ini dilakukan di GNS3.

topologi

Petunjuk Lab

1. Advertise IP loopback 0 pada R2 dan R3 menggunakan RIP.

2. Advertise interface serial antara R2 dan R3 menggunakan RIP.

3.  Buat IP loopback baru di R3.

4. Konfigurasi eBGP Peers antara R2 dan R3 menggunakan loopback.

 

Konfigurasikan masing – masing router anda dan ketika di show run akan muncul seperti di bawah ini.

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 1.0.0.0
network 12.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router rip
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 12
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 255
neighbor 3.3.3.3 update-source Loopback0
no auto-summary

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router rip
network 3.0.0.0
network 23.0.0.0
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

 

Setelah selesai melakukan konfigurasi seperti di atas, langkah selanjutnya adalah melakukan verifikasi. Hal ini bertujuan untuk memastikan konfigurasi yg kita lakukan benar dan jaringan berjalan dengan baik.

ping

sh ip bgp

sh ip route

Setelah mempelajari internal BGP kini saatnya mempelajari cara menjalin koneksi dengan AS number yg berbeda pada routing BGP, atau yg sering disebut dengan eBGP.

Tambahkan 1 router di sisi R2 dari topologi sebelumnya.

topologi

Petunjuk lab

1. R1 dan R2 masih menggunakan pengalamatan seperti pada artikel sebelumnya.

2. Tambahkan konfigurasi IP antara R2 dan R3.

3. Buat eBGP peers antara router R2 dan R3.

4. Konfigurasikan IP loopback di R3 untuk di advertise ke BGP.

Konfigurasi masing – masing routernya sebagai berikut.

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 1.0.0.0
network 12.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback1
no auto-summary

 

R2

interface Loopback0
ip address 22.22.22.22 255.255.255.255
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router rip
network 2.0.0.0
network 12.0.0.0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 22.22.22.22 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback1
neighbor 23.23.23.3 remote-as 3
no auto-summary

 

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
clock rate 2000000
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 23.23.23.2 remote-as 12
no auto-summary

Verifikasi hasil kerja konfigurasi anda, ping dari ujung ke ujung. loopback r1 ke loopback r3, loopback r1 ke loopback r2.

ip bgp

ip route

ping 2

ping