Tag Archive: mpls


MPLS LDP Authentication

Kita bisa mengamankan peering neighbor LDP dengan menambahkan autentikasi pada peering antar neighbor LDP. Autentikasi yang digunakana adalah MD5, ada beberapa cara dalam menerapkan autentikasi. Agar lebih memahaminya langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk Lab.

1. Setting konfigurasi IP dan routingnya menggunakan OSPF.

2. Setting protocol LDPnya menggunakan LDP OSPF autoconfig, seperti pada postingan saya sebelumnya. Silahkan cek disini.

3. Lalu tambahkan konfigurasi berikut untuk autentikasinya.

R1(config)#mpls ldp neighbor 2.2.2.2 password cisco   (Menentukan otentikasi antara dua neighbor LDP)

R2)config)#mpls ldp password required   (Menentukan bahwa LDP harus menggunakan password ketika akan membangun sesi antara LDP peeringnya)
R2(config)#mpls ldp password option 1 for r2-r3 idnr2r3  (Untuk mengkonfigurasi autentikasi LDP MD5, dengan neighbor yg sudah didaftarkan dlm access list saja)
R2(config)#mpls ldp neighbor 1.1.1.1 password cisco
R2(config)#ip access-list standard r2-r3
R2(config-std-nacl)#permit 2.2.2.2
R2(config-std-nacl)#permit 3.3.3.3

R3(config)#mpls ldp password required
R3(config)#mpls ldp password option 1 for r2-r3 idnr2r3
R3(config)#mpls ldp neighbor 4.4.4.4 password idnr4
R3(config)#mpls label protocol ldp
R3(config)#ip access-list standard r2-r3
R2(config-std-nacl)#permit 2.2.2.2
R2(config-std-nacl)#permit 3.3.3.3

R4(config)#mpls ldp password required
mpls ldp password fallback idnr4    (mengkonfigurasi password MD5 untuk sesi LDP dengan peeringnya)

 

4. Verifikasi

Cek autentikasi yg digunakan pada R1, terlihat MD5 sudah aktif tp tidak meminta password, karena pada R1 tidak di konfigurasikan “password required”. Menggunakan autentikasi neigbor seperti yg dikonfigurasikan di atas.

r1 nei r2

Cek autentikasi pada R2, sesuai dengan konfigurasi autentikasi R2 di atas sehingga untuk peering dengan router R2 membutuhkan password (Password : required).

Untuk terhubung ke R1 menggunakan autentikasi neighbor dan ke R3 menggunakan autentikasi option.

r2 r1 dan r2 r3

Cek autentikasi pada R3, untuk berkomunikasi ke R4 menggunakan mode neighbor dan ke R2 menggunakan mode option.
r3 r2 option 1

Cek konfigurasi pada R4, untuk peering neighbor ke R3 menggunakan mode fallback.

r4 fallback

Iklan

Pada artikel kali ini kita akan mencoba untuk konfigurasi mpls pada interface secara otomatis, menggunakan routing OSPF. Jadi kita tidak perlu menambahkan command “mpls ip” pada tiap2 interface. Hanya perlu 1 command pada routingya, interface yang terhubung langsung ke OSPF akan otomatis terbentuk sebagai interface mpls.

Langsung saja kita labkan, buat topologi seperti di bawah ini.

topologi

Petunjuk LAB

1. Setting IP dan routing OSPF pada topologi diatas, pastikan semua router bisa saling ping loopbacknya.

R1(config)#interface Loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#interface GigabitEthernet0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#interface GigabitEthernet0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#interface GigabitEthernet1/0
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config)#router ospf 1
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#interface Loopback0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#interface GigabitEthernet0/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#interface GigabitEthernet1/0
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

R4(config)#interface Loopback0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#interface GigabitEthernet0/0
R4(config-if)#ip address 34.34.34.4 255.255.255.0
R4(config)#router ospf 1
R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

2. Setting MPLS Label Distribution dengan protocol LDP pada semua interface.

R1-R4(config)#mpls label protocol ldp

3. Setting MPLS LDP router-id, gunakan IP loopback pada masing – masing router.

R1-R4(config)#mpls ldp router-id Loopback0 (menjadikan loopback router, menjadi router-id pada mpls ldp)

4. Setting MPLS LDP autoconfig pada routing ospf, untuk mengaktifkan fungsi konfigurasi mpls otomatis pada interface.

R1-R4(config)#router os 1

R1-R4(config-router)#mpls ldp autoconfig

5. Verifikasi

Show run dari konfigurasi di atas.

sh run ldp autoconfig

Cek interface MPLSnya, sudah berbeda dengan postingan sebelumnya. Jika menggunakan autoconfig, ldpnya menjadi IGP config.

sh mpls int detail

Untuk mematikan fungsi mpls pada suatu interface tidak bisa dilakukan dengan command “no mpls ip”, tp menggunakan command “no mpls ldp igp autoconfig”

no ldp igp autoconf

sh run r1 stlh no ldp auto

Setelah dimatikan fungsi mplsnya, ada beberapa cara untuk mengaktifkannya lagi.

aktifkan mpls int

KIta coba gunakan command “mpls ip” pada tiap2 interface lalu cek lagi hasilnya.

sh mpls int detail dobel

Sebenarnya kita sudah menggunakan routing ospf pada vpn di postingan saya yg berjudul mpls traffing engineering, kali ini saya akan membuatnya lebih simple agar lebih mudah dipahami.

Langsung saja, topologinya ada di bawah ini. Dan kita akan menerapkannya pada network bank BRI.

topologi

Petunjuk LAB

1. Untuk MPLS backbone masih menggunakan topologi dan konfigurasi pada artikel sebelumnya yaitu MPLS VPN, silahkan lihat disini

2. Konfigurasi routing BGP pada PE1 dan PE2, lalu redistribute ke BGP yg sudah dikonfigurasi sebelumnya.

Router PE1

router ospf 100 vrf bri.kiri
redistribute bgp 65000 subnets         (agar network classfull dan classless semuanya bisa redistribute, karena apabila tanpa “subnets” hanya network classfull saja yg di redistribute)
network 192.168.0.1 0.0.0.0 area 0

router 65000

address-family ipv4 vrf bri.kiri
redistribute ospf 100 vrf bri.kiri match internal external 1 external 2       (agar tipe OSPF yang diredistribute ke BGP adalah hanya OSPF tipe internal saja, jadi yg ada pada routing tabel hanya “O IA” saja)

Router PE2

router ospf 100 vrf bri.kanan
redistribute bgp 65000 subnets
network 192.168.0.5 0.0.0.0 area 0

router 65000

address-family ipv4 vrf bri.kanan
redistribute ospf 100 vrf bri.kanan match internal external 1 external 2

3. Konfigurasi IP addess dan routing BGP pada router BCA.KIRI dan BCA.KANAN

Router R4 BRI.KIRI

conf r4

Router BRI.KANAN

conf r5

Verifikasi

Ping dari BRI kiri ke BRI kanan dan ke PE1 dan PE2

PING R4

Lakukan traceroute pastikan jalurnya menggunakan jalur mpls.

tracer r5

Lihat routing tabelnya, pastikan sudah menggunakan routing OSPF.

sh ip route r5

Berikut ini hasil bila dilakukan show run di tiap routernya.

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 100 vrf bri.kiri
log-adjacency-changes
redistribute bgp 65000 subnets
network 192.168.0.1 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kiri
redistribute ospf 100 vrf bri.kiri match internal external 1 external 2
no synchronization
exit-address-family

Router P

interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface Serial0/1
ip address 192.168.20.1 255.255.255.252
mpls ip
clock rate 2000000
!
router ospf 1
mpls ldp autoconfig
log-adjacency-changes
network 10.10.10.10 0.0.0.0 area 0
network 192.168.10.2 0.0.0.0 area 0
network 192.168.20.1 0.0.0.0 area 0

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 100 vrf bri.kanan
log-adjacency-changes
redistribute bgp 65000 subnets
network 192.168.0.5 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf bri.kanan
redistribute ospf 100 vrf bri.kanan match internal external 1 external 2
no synchronization
exit-address-family

R4 BRI KIRI

interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0

R5 BRI KANAN

interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0

Kita sudah mempelajari berbagai macam routing pada MPLS, mulai dari static hingga dinamic (RIP dan EIGRP). Masih ada routing dinamic yaitu BGP. Pada lab kali ini kita akan mencoba menerapkan routing BGP pada jaringan MPLS.

Topologinya ada di bawah ini, kita akan menerapkan BGP pada BANK BCA.

topologi

Petunjuk LAB

1. Untuk MPLS backbone masih menggunakan topologi dan konfigurasi pada artikel sebelumnya yaitu MPLS VPN, silahkan lihat disini

 

2. Konfigurasi routing BGP pada PE1 dan PE2, lalu redistribute ke BGP yg sudah dikonfigurasi sebelumnya.

Router PE1

router bgp 65000

address-family ipv4 vrf bca.kiri
neighbor 192.168.0.2 remote-as 100 (Memasukkan IP PE2 ke dalam routing tabel BGP router PE1)
neighbor 192.168.0.2 activate              (Untuk mengaktifkan pertukaran informasi dengan protocol BGP lawan)
neighbor 192.168.0.2 as-override      (Untuk mencegah routing loop dari router yg sama2 mengaktifkan vpn dan memliki AS number yg sama)
network 192.168.0.0 mask 255.255.255.252 (Memasukkan alamat network yg akan digunakan untuk berkomunikasi dari PE1 ke PE2 ke dalam routing tabel BGP)

 

Router PE2

router bgp 65000

address-family ipv4 vrf bca.kanan
neighbor 192.168.0.6 remote-as 100
neighbor 192.168.0.6 activate
neighbor 192.168.0.6 as-override
network 192.168.0.4 mask 255.255.255.252

 

3. Konfigurasi IP addess dan routing BGP pada router BCA.KIRI dan BCA.KANAN

R6 BCA KIRI

router bgp 100
network 6.6.6.6 mask 255.255.255.255
network 192.168.0.0 mask 255.255.255.252
neighbor 192.168.0.1 remote-as 65000

 

R7 BCA KANAN

router bgp 100
network 7.7.7.7 mask 255.255.255.255
network 192.168.0.4 mask 255.255.255.252
neighbor 192.168.0.5 remote-as 65000

 

Verifikasi

Lakukan ping ke interface PE yg terhubung ke bank  BCA, dan loopback semua router BCA

ping r7

Lakukan traceroute untuk memastikan trafik sudah melalui jalur yg benar dan melalui jalur MPLS.

tracer r6

terlihat trafik dari R6 ke R7, melalui PE1 yg merupakan jalur MPLS kemudian langsung ke PE2 yg menggunakan routing BGP dengan AS number 65000

tracer r7

Cek routing tabelnya pastikan sudah menggunakan routing BGP yang bersimbol “B” pada routing tabel.

sh ip route r6

 

Hasil show run dari lab kali ini adalah sebagai berikut.

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family

address-family ipv4 vrf bca.kiri
neighbor 192.168.0.2 remote-as 100
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 as-override
no synchronization
network 192.168.0.0 mask 255.255.255.252
exit-address-family

 

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf bca.kanan
neighbor 192.168.0.6 remote-as 100
neighbor 192.168.0.6 activate
neighbor 192.168.0.6 as-override
no synchronization
network 192.168.0.4 mask 255.255.255.252
exit-address-family

 

Router R6 BCA KIRI

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.252
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 6.6.6.6 mask 255.255.255.255
network 192.168.0.0 mask 255.255.255.252
neighbor 192.168.0.1 remote-as 65000
no auto-summary

 

Router 7 BCA KANAN

interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 7.7.7.7 mask 255.255.255.255
network 192.168.0.4 mask 255.255.255.252
neighbor 192.168.0.5 remote-as 65000

MPLS VPN

Setelah berhasil membuat backbone mpls pada postingan sebelumnya, kini saatnya membuat jaringan mpls vpn. MPLS VPN digunakan untuk membuat jalur privat dari satu node ke node lainnya dalam jaringan umum. Contoh topologinya seperti di bawah ini.

topologi

Pada jaringan di atas terlihat bahwa Bank BRI dan Bank BCA membuat jaringan privat dengan IP yang satu range, seolah – olah antara bank BCA.KIRI dan bank BCA.KANAN dalam satu jaringan yang sama. Padahal mereka sebenarnya melalui jaringan internet atau publik untuk berkomunikasi satu sama lain.

Adapun tahapan konfigurasi membuat MPLS VPN adalah sebagai berikut :

Pada router PE :

  1. Membuat VRF
  2. Konfigurasikan IP address dan VRF pada PE yg nenuju CE
  3. Mengaktifkan MP-BGP
  4. Menambahkan routing PE-CE

Pada CE router

  1. Konfigurasi IP address CE
  2. Konfigurasi default route

1. Membuat VRF

  • VRF (Virtual Router Forwarding)  diperlukan untuk setiap customer, misalnya terdapat 2 customer maka kita juga mengkonfigurasikan 2 VRF.
  • Virtual Router ini seolah-olah seperti masing-masing customer memiliki router sendiri yang mengatur trafik mereka melalui MPLS domain.
  • Masing-masing VRF memiliki identitas sendiri-sendiri untuk setiap customer
  • Karena VRF inilah, dimungkinkan customer berbeda namun memiliki IP Address yang sama dapat diakomodir menggunakan MPLS network

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1

Pada PE1 terdapat 2 customer yakni BRI.KIRI dan BCA.KIRI, maka dibuat 2 VRF yang bernama vrf bri.kiri dan vrf bca.kiri VRF memiliki 2 komponen utama yaitu :

  1. RD (Route Distinguisher)
  • RD merupakan identitas dari sebuah VRF
  • Setiap customer memiliki VRF sendiri
  • Penulisan RD dapat dituliskan seperti format berikut
    • 16-bit AS Number : 32-bit number –> contoh : 65000 : 1
    • 32-bit IP Address  : 15-bit number –> contoh : 192.168.0.1 : 1
  • RT (Route Target)
    • RT digunakan untuk menentukan route yang mana yang akan di import ke dalam VRF dan menentukan route yang mana yang akan di export
    • Sifatnya seperti routing policy
    • Format penulisannya seperti RD yakni seperti berikut
      • 16-bit AS Number : 32-bit number –> contoh : 65000 : 1
      • 32-bit IP Address  : 15-bit number –> contoh : 192.168.0.1 : 1

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1

Pada PE2 konfigurasi vrfnya sama dengan PE1, yg berbeda hanya nama vrfnya saja.

2. Konfigurasi IP Address & VRF pada PE yang menuju CE

Setelah VRF dikonfigurasikan, maka kita bisa mengkonfigurasikan IP Address yang sama pada beberapa interface router. Tanpa VRF, pada router tidak bisa dikonfigurasikan IP Address yang sama kecuali di bridging.

Router PE1

interface FastEthernet0/0
ip vrf forwarding bri.kiri                                  (link ke BRI KIRI)
ip address 192.168.0.1 255.255.255.252
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri                                  (link ke BCA KIRI)
ip address 192.168.0.1 255.255.255.252

Router PE2

interface FastEthernet0/0
ip vrf forwarding bri.kanan                             (link ke BRI KANAN)
ip address 192.168.0.5 255.255.255.252
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan                            (link ke BCA KANAN)
ip address 192.168.0.5 255.255.255.252

  3. Mengaktifkan MP-BGP

MP-BGP (Multi Protocol BGP) digunakan untuk membawa informasi routing, IPv4 prefixes, VPN Customer dan lain-lain menuju Router PE lainnya.

Router PE1

router bgp 65000
address-family vpnv4
neighbor 10.10.10.2 activate

Router PE2

router bgp 65000
address-family vpnv4
neighbor 10.10.10.1 activate

Selanjutnya gunakan routing protokol. Routing protokol yang digunakan pada koneksi router PE dan CE ada beberapa pilihan antara lain :

  1. Static
  2. RIPv2
  3. EIGRP
  4. OSPF
  5. BGP

Lakukan verifikasi

Terlihat vrf yg telah dibuat sudah masuk, dan nlai RDnya pun juga, dan ip loopback semua router sudah masuk ke dalam routing tabel.

pe1

verifikasi pe2

Hasil show run dari lab kali ini adalah sebagai berikut

Router PE1

ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kiri
ip address 192.168.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community

Router PE2

ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding bri.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.20.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface FastEthernet0/1
ip vrf forwarding bca.kanan
ip address 192.168.0.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family

Router P

interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
mpls ip
clock rate 2000000
!
interface Serial0/1
ip address 192.168.20.1 255.255.255.252
mpls ip
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 10.10.10.10 0.0.0.0 area 0
network 192.168.10.2 0.0.0.0 area 0
network 192.168.20.1 0.0.0.0 area 0

Telah dibahas mengenai jaringan MPLS traffic engineering serial pada postingan sebelumnya, kali ini akan kita pelajari yang berbasis Fast Ethernet.

Masih menggunakan topologi sebelumnya, perbedaannya hanya pada pengkabelannya saja.

topologi

Petunjuk lab

Masih menggunakan konfigurasi postingan sebelumnya, rubah interface serial ke fast ethernet dan sebaliknya.

Untuk konfigurasi lengkapnya sebagai berikut.

CE1A

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
network 5.5.5.5 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0

CE1B

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.10.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
network 6.6.6.6 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0

P1

mpls traffic-eng tunnels                                         (digunakan untuk mengaktifkan fungsi mpls traffic engineering)

!

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000                         (digunakan untuk menentukan kapasitas bandwidth pada interface itu)
!
interface FastEthernet0/1
ip address 24.24.24.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 24.24.24.0 0.0.0.255 area 0

P2

mpls traffic-eng tunnels

!

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 13.13.13.2 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface Serial0/1
ip address 34.34.34.1 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
router ospf 1
mpls traffic-eng router-id Loopback0                      (digunakan untuk memberi router-id pada routing ospf)
mpls traffic-eng area 0
network 3.3.3.3 0.0.0.0 area 0
network 13.13.13.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0

PE1

ip vrf COSTUMER
rd 1:1                                                       (identitas dari sebuah vrf)
route-target export 1:1                   (menentukan route mana yang mana akan di import ke vrf)
route-target import 1:1                   (menentukan route mana yang mana akan di export ke vrf)
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0              (memberikan alamat IP pd interface tunnel, harus diset unnumbered krn merupakan link searah)
tunnel destination 4.4.4.4                 (menentukan IP tujuan untuk interface tunnel)
tunnel mode mpls traffic-eng           (mengaktifkan fitur mpls TE pada interface tunnel)
tunnel mpls traffic-eng autoroute announce                   (menentukan pemilihan jalur routing terbaik secara otomatis, bila link down)
tunnel mpls traffic-eng priority 1 1                                      (mengkonfigurasi pengaturan dan prioritas reservasi untuk tunnel)
tunnel mpls traffic-eng bandwidth 100                              (mengkonfigurasi bandwidth yg dibutuhkan untuk tunnel)
tunnel mpls traffic-eng path-option 1 explicit identifier 1                     (menentukan pemilihan jalur utama dari identifier yg kita buat)
!
interface FastEthernet0/0
ip vrf forwarding COSTUMER                                   (Virtual Router Forwading, digunakan untuk mengatur trafik melalui MPLS Domain)
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 13.13.13.1 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface FastEthernet0/1
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
router ospf 100 vrf COSTUMER
redistribute bgp 1 subnets                                              (digunakan untuk mengadvertise routing BGP ke OSPF)
network 192.168.0.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 13.13.13.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
router bgp 1
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4                     (mengaktifkan fungsi multiprotocol BGP, untuk membawa informasi routing, IPv4 prefix, VPN, dll)
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended      (mengirimkan atribut bgp ke tujuan yg telah ditentukan)
!
address-family ipv4 vrf COSTUMER
redistribute ospf 100 vrf COSTUMER match internal external 1 external 2     (secara default redistribute ospf hanya internal saja,                         dikonfigurasikan command tersebut agar redistribute nya bisa type external 1 dan external 2)
!
ip explicit-path identifier 1 enable                  (mendifinisikan nama jalur dan alamat IP yang dilewati jalur tersebut)
next-address 12.12.12.2
next-address 24.24.24.2
next-address 4.4.4.4
!
ip explicit-path identifier 2 enable                  (mendifinisikan nama jalur dan alamat IP yang dilewati jalur tersebut)
next-address 13.13.13.2
next-address 34.34.34.2
next-address 4.4.4.4

PE2

ip vrf COSTUMER
rd 1:1
route-target export 1:1
route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface Serial0/0
ip address 34.34.34.2 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface FastEthernet0/1
ip vrf forwarding COSTUMER
ip address 192.168.10.5 255.255.255.0
duplex auto
speed auto
!
router ospf 100 vrf COSTUMER
redistribute bgp 1 subnets
network 192.168.10.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
network 4.4.4.4 0.0.0.0 area 0
network 24.24.24.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
router bgp 1
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
!
address-family ipv4 vrf COSTUMER
redistribute ospf 100 vrf COSTUMER match internal external 1 external 2

verifikasi

Pastikan tujuan mpls kita benar, dan statusnya UP.

tunnels brief

Pada explicit route pada gambar di bawah ini, terlihat jalur utama sudah benar. Yaitu melalui jalur atas, 12.12.12.2 24.24.24.2 4.4.4.4

tunnel destination

Lakukan ping dan tracerouter dari  PC1 ke PC2 dan sebaliknya, untuk memastikan koneksi dan jalur yang dilalui sudah benar.

ping tracer pc2 ke pc1

ping tracer pc1 ke pc2

Lakukan ping secara terus menerus, kemudian matikan link utama seperti di bawah ini.

PE1(config)#int fa0/1

PE1(config-if)#shutdown

Terlihat pada gambar di bawah ini link sempat terputus sebentar untuk kemudian berpindah ke link backup.

saat pe1 fa00 dimatikan

Lakukan tracer setelah link utama dimatikan, terlihat jalur sudah pindah ke jalur bawah yaitu jalur serial. Terlihat ada IP 34.34.34.1 yang merupakan IP PE2 yang menuju ke jalur bawah.

tracer link backup

Multi-protocol label switching (MPLS) adalah arsitektur network yang didefinisikan oleh IETF untuk memadukan mekanisme label swapping di layer 2 dengan routing di layer 3 untuk mempercepat pengiriman paket.

Pada proses forwarding, protokol ini menentukan forwarding berdasarkan label pada paket. Label yang pendek dan berukuran tetap mempercepat proses forwarding dan mempertinggi fleksibilitas pemilihan path. Hasil forwarding adalah network datagram yang bersifat lebih connection-oriented yaitu setiap virtual circuit harus disetup dengan protokol persinyalan sebelum transmisi (proses signaling).

Pada skenario topologi di bawah ini akan dibuat jaringan MPLS antara router PE 1 dan PE 2, dengan kabel serial sebagai jalur utama dan fast ethernet sebagai link backup.

topologi

Petunjuk lab

1. Lakukan konfigurasi IP bebas, untuk lebih mudahnya ikuti saja topologi di atas.

CE1A

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
clock rate 2000000

CE1B

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.10.6 255.255.255.0
clock rate 2000000

P1

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 24.24.24.1 255.255.255.0

P2

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.2 255.255.255.0
!
interface FastEthernet0/1
ip address 34.34.34.1 255.255.255.0

PE1

interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.0.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 12.12.12.1 255.255.255.0

2. Routing yang digunakan pada seluruh topologi di atas adalah OSPF area 0.

CE1A

router ospf 1
network 5.5.5.5 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0

CE1B

router ospf 1
network 6.6.6.6 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0

P1

router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 24.24.24.0 0.0.0.255 area 0

P2

router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 13.13.13.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0

PE1

router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 13.13.13.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0

PE2

router ospf 1
network 4.4.4.4 0.0.0.0 area 0
network 24.24.24.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0

3. Pada PE1 dan PE2 konfigurasikan routing BGP.

PE1

router bgp 1
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0

PE2

router bgp 1
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0

4. Aktifkan fungsi MPLS pada PE1, PE2, P1 dan P2.

Router P1

P1(config)#mpls ip

P1(config)#interface Serial0/0/0

P1(config-if)#mpls ip

P1(config)#interface Serial0/0/1

P1(config-if)#mpls ip

Router P2

P2(config)#mpls ip

P2(config)#interface FastEthernet0/0

P2(config-if)#mpls ip

P2(config)#interface FastEthernet0/1

P2(config-if)#mpls ip

Router PE1

PE1(config)#mpls ip

PE1(config)#interface Serial0/0/1

PE1(config-if)#mpls ip

PE1(config)#interface FastEthernet0/0

PE1(config-if)#mpls ip

Router PE2

PE2(config)#mpls ip

PE2(config)#interface Serial0/0/0

PE2(config-if)#mpls ip

PE2(config)#interface FastEthernet0/0

PE2(config-if)#mpls ip

5. Buat IP vrf pada PE1 dan PE2.

PE1

PE1(config)#ip vrf COSTUMER

PE1(config-vrf)#rd 1:1

PE1(config-vrf)#route target both 1:1

PE2

PE2(config)#ip vrf COSTUMER

PE2(config-vrf)#rd 1:1

PE2(config-vrf)#route target both 1:1

6. Masukkan IP vrf forwarding pada interface PE yang menuju CE.

PE1

PE1(config)#interface Serial0/0/0

PE1(config-if)#ip vrf forwarding customer

PE1(config-if)#ip address 192.168.0.2 255.255.255.0

PE2

PE2(config)#interface Serial0/0/1

PE2(config-if)#ip vrf forwarding customer

PE2(config-if)#ip address 192.168.10.5 255.255.255.0

7. Aktifkan fungsi Multiprotocol BGP.

PE1

PE1(config)#router bgp 1

PE1(config-router)#address-family vpnv4

PE1(config-router-af)#neighbor 4.4.4.4 activate

PE2

PE2(config)#router bgp 1

PE2(config-router)#address-family vpnv4

PE2(config-router-af)#neighbor 1.1.1.1 activate

8. Menambahkan routing PE-CE

PE1

PE1(config)#router ospf 100 vrf COSTUMER

PE1(config-router)#redistribute bgp 1 subnets

PE1(config-router)#network 192.168.0.0 0.0.0.255 area 0

PE1(config)#router bgp 1

PE1(config-router)#address-family ipv4 vrf COSTUMER

PE1(config-router-af)#redistribute ospf 100 vrf customer match internal external 1 external 2

PE2

PE2(config)#router ospf 100 vrf customer

PE2(config-router)#redistribute bgp 1 subnets

PE2(config-router)#network 192.168.10.0 0.0.0.255 area 0

PE2(config)#router bgp 1

PE2(config-router)#address-family ipv4 vrf customer

PE2(config-router-af)#redistribute ospf 100 vrf customer match internal external 1 external 2

9. Konfigurasikan default route pada router CE

Router CE1A

CE1A(config)#router ospf 1

CE1A(config-router)#network 0.0.0.0 255.255.255.255 area 0

Router CE1B

CE1B(config)#router ospf 1

CE1B(config-router)#network 0.0.0.0 255.255.255.255 area 0

9. Mengaktifkan Traffic Engineering.

Router P1

P1(config)#mpls traffic-eng tunnels

P1(config)#interface Serial0/0/0

P1(config-if)#mpls traffic-eng tunnels

P1(config)#interface Serial0/0/1

P1(config-if)#mpls traffic-eng tunnels

Router P2

P2(config)#mpls traffic-eng tunnels

P2(config)#interface FastEthernet0/0

P2(config-if)#mpls traffic-eng tunnels

P2(config)#interface FastEthernet0/1

P2(config-if)#mpls traffic-eng tunnels

Router PE1

PE1(config)#mpls traffic-eng tunnels

PE1(config)#interface Serial0/0/1

PE1(config-if)#mpls traffic-eng tunnels

PE1(config)#interface FastEthernet0/0

PE1(config-if)#mpls traffic-eng tunnels

Router PE2

PE2(config)#mpls traffic-eng tunnels

PE2(config)#interface Serial0/0/0

PE2(config-if)#mpls traffic-eng tunnels

PE2(config)#interface FastEthernet0/0

PE2(config-if)#mpls traffic-eng tunnels

10. Mengkonfigurasikan RSVP Bandwidth.

Router P1

P1(config)#interface Serial0/0/0

P1(config-if)#ip rsvp bandwidth 100 100

P1(config)#interface Serial0/0/1

P1(config-if)#ip rsvp bandwidth 100 100

Router P2

P2(config)#interface FastEthernet0/0

P2(config-if)#ip rsvp bandwidth 1000 1000

P2(config)#interface FastEthernet0/1

P2(config-if)#ip rsvp bandwidth 1000 1000

Router PE1

PE1(config)#interface Serial0/0/1

PE1(config-if)#ip rsvp bandwidth 100 100

PE1(config)#interface FastEthernet0/0

PE1(config-if)#ip rsvp bandwidth 1000 1000

Router PE2

PE2(config)#interface Serial0/0/0

PE2(config-if)#ip rsvp bandwidth 100 100

PE2(config)#interface FastEthernet0/0

PE2(config-if)#ip rsvp bandwidth 1000 1000

11. Membuat interface Tunnel pada Head-end Router PE1.

PE1(config)#interface Tunnel0

PE1(config-if)#ip unnumbered Loopback 0

PE1(config-if)#tunnel destination 4.4.4.4

PE1(config-if)#tunnel mode mpls traffic-eng

PE1(config-if)#tunnel mpls traffic-eng priority 1 1

PE1(config-if)#tunnel mpls traffic-eng bandwidth 100

PE1(config-if)#tunnel mpls traffic-eng path-option 1 explicit identifier 1

12. Mengaktifkan Tunnel jalur utama untuk OSPF.

PE1(config)#interface Tunnel0

PE1(config-if)#tunnel mpls traffic-eng autoroute announce

13. Mengaktifkan Path untuk jalur utama.

PE1(config)#interface Tunnel0

PE1(config-if)#tunnel mpls traffic-eng path-option 1 explicit identifier 1

14. Menentukan jalur untuk Tunnel jalur utama dan jalur kedua.

Router PE1

PE1(config)#ip explicit-path identifier 1

PE1(cfg-ip-expl-path)#next-address 12.12.12.2

PE1(cfg-ip-expl-path)#next-address 24.24.24.2

PE1(cfg-ip-expl-path)#next-address 4.4.4.4

PE1(config)#ip explicit-path identifier 2

PE1(cfg-ip-expl-path)#next-address 13.13.13.2

PE1(cfg-ip-expl-path)#next-address 34.34.34.2

PE1(cfg-ip-expl-path)#next-address 4.4.4.4

15. Mengaktifkan area OSPF untuk Traffic Engineering

Router P1

P1(config)#router ospf 1

P1(config-router)#mpls traffic-eng router-id Loopback0

P1(config-router)#mpls traffic-eng area 0

Router P2

P2(config)#router ospf 1

P2(config-router)#mpls traffic-eng router-id Loopback0

P2(config-router)#mpls traffic-eng area 0

Router PE1

PE1(config)#router ospf 1

PE1(config-router)#mpls traffic-eng router-id Loopback0

PE1(config-router)#mpls traffic-eng area 0

Router PE2

PE2(config)#router ospf 1

PE2(config-router)#mpls traffic-eng router-id Loopback0

PE2(config-router)#mpls traffic-eng area 0

Untuk konfigurasi lengkapnya bisa dilihat pada konfigurasi di bawah ini.

CE1A

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0

CE1B

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.10.6 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0

P1

mpls traffic-eng tunnels

!

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface Serial0/1
ip address 24.24.24.1 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 24.24.24.0 0.0.0.255 area 0

P2

mpls traffic-eng tunnels

!

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.2 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface FastEthernet0/1
ip address 34.34.34.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 13.13.13.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0

PE1

ip vrf COSTUMER
rd 1:1
route-target export 1:1
route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 4.4.4.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng path-option 1 explicit identifier 1
no routing dynamic
!
interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface Serial0/0
ip vrf forwarding COSTUMER
ip address 192.168.0.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1
ip address 12.12.12.1 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
router ospf 100 vrf COSTUMER
log-adjacency-changes
redistribute bgp 1 subnets
network 192.168.0.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.0 0.0.0.255 area 0
network 13.13.13.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf COSTUMER
redistribute ospf 100 vrf COSTUMER match internal external 1 external 2
no synchronization
exit-address-family
!
ip explicit-path identifier 1 enable
next-address 12.12.12.2
next-address 24.24.24.2
next-address 4.4.4.4
!
ip explicit-path identifier 2 enable
next-address 13.13.13.2
next-address 34.34.34.2
next-address 4.4.4.4

PE2

ip vrf COSTUMER
rd 1:1
route-target export 1:1
route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.2 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 1000 1000
!
interface Serial0/0
ip address 24.24.24.2 255.255.255.0
mpls ip
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 100 100
!
interface Serial0/1
ip vrf forwarding COSTUMER
ip address 192.168.10.5 255.255.255.0
clock rate 2000000
!
router ospf 100 vrf COSTUMER
log-adjacency-changes
redistribute bgp 1 subnets
network 192.168.10.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 24.24.24.0 0.0.0.255 area 0
network 34.34.34.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf COSTUMER
redistribute ospf 100 vrf COSTUMER match internal external 1 external 2
no synchronization
exit-address-family

Lakukan verifikasi sebagai berikut

1. Ping dan traceroute dari PC1 ke PC2, pastikan trafik melalui jalur atas. Yaitu serial yang dijadikan jalur utama.

ping trace pc1 ke pc2

2. Pastikan interface tunnel sudah UP.

tunnels brief

3. Pada verifikasi di bawah terlihat status tunnel sudah UP dan trafik melalu jalur atas yaitu 12.12.12.2, 24.24.24.2

tunnel destination

4. Coba matikan main link yaitu jalur atas dengan mengetikkan perintah

PE2(config)#int s0/0

PE2(config-if)#shutdown

ping pc1 ke pc2 failover

5. Kemudian lakukan traceroute kembali ke PC2

trace pc1 ke pc2 failover

Terlihat jalur telah berpindah ke jalur backup yaitu jalur bawah (fast ethernet), dengan IP 13.13.13.2